Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My MBP (13inch, late 2011) sometimes loses it's startup disk when I have powered it off by holding the power button for 10 seconds. Not every time, but one time out of 5.

(See my other question on my MBP locking up when entering clamshell mode for why I have been having to do this.)

When this happens, I get the folder with a question mark. Rebooting with "Alt" despressed, I have to initiate a "network recovery" (only option). In recovery, I select the "startup disk" from the Apple menu on the menubar. All is fine then, but it sure is a pain.

I am using a Crucial M4 SSD, not the stock disk if that matters.

Any pointers would be helpful.

BTW: It might have started with MountainLion. My problem which causes me to need to hold the power button started with ML, so I never reset the mac this way before.

Thanks. Kent

share|improve this question
    
Your NVRAM is being reset. –  duci9y Nov 11 '12 at 15:23
    
Is there a way to boot w/o network recovery? Even booting from the local recovery partition would be a big step forward! (Cmd-R doesn't seem to work.) –  KentH Nov 11 '12 at 21:36
    
As your Recovery HD is on your HD, and your HD can’t be detected, you can’t recover without the network. –  duci9y Nov 12 '12 at 12:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.