Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I enabled the System Preferences > Trackpad > Tap to Click which causes it to work while I am logged in. However, in the login screen, it does not work. How can I get this setting enabled in the login screen as well?

share|improve this question
    
+1 I has the same question –  Nivas Jan 29 '11 at 4:37
    
Did you try this or were you just wondering? –  conorgriffin Jan 31 '11 at 21:16
    
Do none of the answers work for you? –  Mathias Bynens Apr 10 '12 at 12:34

3 Answers 3

Open Terminal and enter the following commands

  1. defaults write com.apple.finder AppleShowAllFiles TRUE
  2. killall Finder

Show Files

In Finder

  1. open Macintosh HD/Library/Preferences
  2. Ctl+click/right-click a file called .GlobalPreferences.plist and click 'Get Info'
  3. Change the permissions to allow you to alter it but make a note/screenshot of what they are first. (be careful here!)
  4. open the file by double-clicking

.GlobalPreferences.plist permissions

Property List Editor will run and open the .plist file

  1. Click 'Root' at the top of the window
  2. Click the 'Add Child' button
  3. Add an entry called com.apple.mouse.tapBehaviour
  4. Make it a Number type
  5. Set the value to 1
  6. Save the file enter image description here

Back in Finder, reset the permissions to what they were

In Terminal enter the following commands

  1. defaults write com.apple.finder AppleShowAllFiles FALSE
  2. killall Finder
    Hide Files

Reboot and the next time you login you should be able to use Tap to click

If you run into issues with Terminal commands or with the plist file make sure your capitalization is correct, case matters!

share|improve this answer

I think that this is impossible but I find below post (but didn't test myself)
according to fds post:

defaults write /Library/Preferences/.GlobalPreferences com.apple.mouse.tapBehavior -int 1
share|improve this answer

I don't know if this is still the case, but the login window's session used to be run as root. So if you enabled the root account, logged in as root, and set whatever trackpad or mouse settings you liked in System Preferences, they would be applied to the login window.

share|improve this answer
1  
I dont think this is true, at least as of 10.6 or later. Just tested it to be sure :-) –  Nivas Jan 29 '11 at 4:37
    
I was afraid of that. Thanks for testing. –  Jonukas Jan 29 '11 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.