Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I encountered a strange problem today. I downloaded FileZilla and on first launch the title bar was above my mouse pointer's reach. Making the window unmovable.

Here is a screenshot of my situation.

screenshot

Is there a way to fix this? I've tried reopening the application and rebooting.

share|improve this question

5 Answers 5

Try going to Window > Zoom in the menubar.

share|improve this answer

Windows that support resizing from all edges can also be moved by for example dragging them horizontally from the bottom edge.

You could also try running something like this in AppleScript Editor:

tell application "System Events" to tell process "FileZilla"
    set position of windows to {100, 100}
end
share|improve this answer

Many applications store window positions in their preferences file(s). A file within ~/Library/Preferences/ is likely associated with this application. To identify the file, go to that directory in Terminal and use the command ls -lt. This lists files sorted by modification time, with recently-modified files at the top. You will likely recognize the associated preference file by name. You can edit the plist file in Xcode, and look for the NSWindow settings to selectively remove them, or simply trash the file. I recommend only modifying or deleting the file while the application is not running.

share|improve this answer

Window > Zoom usually works, but not for all applications (TextWrangler, Eclipse, etc). I found an application called Divvy that allows resizing, using which brings the title bar back into the visible space.

Some googling shows that Slate might be a better option, but I haven't tried it yet

share|improve this answer

Hold on option (or alt) while clicking the Window menu. This should change Bring All to Front into Arrange in Front, which did the trick for me.

This worked for me on OSX 10.9.1

share|improve this answer
    
I've searched all around, and this is the only trick that worked. I tried changing resolution, running a variety of apple scripts, and nothing else worked, but this. Thanks! –  Ernesto May 6 at 2:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.