Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Pretty much every application I use in fullscreen, including Firefox, MacVim and the Terminal, has tabs on the top of the screen. The problem is, when I move my mouse to reach the tabs I acidentally touch the top of the screen, bringing in the OS menu OVER the tabs, often clicking a link there.

Illustration

Is there any way to change this behavior?

share|improve this question
2  
Yeah, this is really annoying. I wish there where a defaults write variable one could edit. But so far I've not heard about anything like that. It is especially annoying when using a VM in full screen. Ubuntu has the menubar at the top and I like it that way. But I'm constantly triggering the OSX menu bar to appear. :( –  gentmatt Nov 8 '12 at 15:25
    
There is ONE thing you can do, but it sacrifices using the menu bar entirely - i.e., in addition to stubbornly hiding it, you can't even manually activate it (via the keyboard shortcut Ctrl+F2) or, it appears, operate any of the menu bar's items via their assigned keyboard shortcuts, either :(. But it DOES get rid of the menu bar out-right if you really want to get rid of it for a specific program. Download 'PresentYourApps' (it's on CNET), run the app you want to remove the menu bar for, run PreentYourApps and set the options for that app accordingly. It'll modify the app and restart it. –  foregon May 10 at 9:13
1  
Ok further info: what 'PresentYourApps' does is basically set the LSUIPresentationMode or 'Application UI Presentation Mode' value in the Info.plist for the app in question: documentation here and a guide at Lifehacker here. Instead of '4', use numeric value '3' for 'All hidden' mode, which is what my above comment's steps do in that easier GUI - but again, 'All hidden' annoyingly disables ALL access to the menu bar when in that app, while 'All suppressed' DOES hide the menu but the mouse invokes it when hit top of the screen, which we don't want. –  foregon May 10 at 9:57
    
Can you try disabling the option "Displays have separate spaces" on the Mission Control section of the System Preferences app? I know it changes the behavior of the menubar but I can't test it on my current machine because I am not running Mavericks. –  Bruno Philipe Jun 19 at 21:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.