Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I already posted this question in stackoverflow:

http://stackoverflow.com/questions/4811282/mac-os-x-terminal-use-option-as-meta-key-overrides-backslash-in-spanish-keyboar

but I was informed there that this is the right place to ask it.

I check "Use option as meta key" checkbox in Mac OS X Terminal, because I like to use emacs way of moving between words: M-f & M-b.

But if I do that, I can't get the backslash (Option + º; i.e.: Option + key-at-the-left-of-1-in-spanish-keyboard). If I uncheck it, then I can input the backslash, but I don't have M-f & M-b.

Is there a way to get both? This is driving me nuts!

share|improve this question
    
Hm, but Alt-Shift-7 gives you the backslash without remapping something - am I missing something ?? –  user19661 Mar 5 '12 at 9:07

1 Answer 1

And, as I already answered you on stackoverflow, the solution is to put the following line into your ~/.bash_profile , which remaps the unicode character "∫" (Unicode: E288AB, which is what is sent to your terminal right now in your desired configuration when you press Option + °) to the backslash character:

bind '"\033\xE2\x88\xAB"':'"\\"'
share|improve this answer
    
Thanks a lot! That did the trick. –  tomasorti Jan 30 '11 at 15:48
    
Would you mind marking my Answer as the solution then? Also, you´re still having your question open as a duplicate on stackoverflow: stackoverflow.com/questions/4811282/… –  Asmus Feb 5 '11 at 11:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.