Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I received a message yesterday asking something about my Apple ID and concerning one of our other lines that used to be shared on the Apple ID with my phone. We stopped that later and used individual IDs. Since I was in a hurry I just clicked yes and went on. As soon as I did it, now my texts keep coming to myself and when I text that other line it shows in a group message it is from me instead of the other line. And the other line gained my contacts mixed in with that line. What do I do to stop it? It is driving me crazy!

share|improve this question
    
Also, have the new 6.0 software update on this phone. –  Lisa Nov 6 '12 at 18:45
add comment

1 Answer

I just figured this out as I had the same issue.

What you need to do is click on your Settings app and scroll down to the green messages icon, click on that and scroll down to the Send & Receive setting. Next to this, it will have the number of addresses, that is: two addresses, click on this and untick the number and email address that are not yours. This should cure the problem for you.

If you have FaceTime active, then I’d advise checking it to make sure that only your number and your email address are filled in.

share|improve this answer
add comment

protected by Community Sep 19 '13 at 0:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.