Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My iMac has been running horrendously slow the past couple days, so I booted into the Snow Leopard CD and ran a disk repair and a permissions repair. Now I can't get past the spinner. It's been going for about 4 hours now with no shows of progress. Does any body have any ideas on what else I can try (I already tried doing the repairs again) or is there any way I can debug this?

share|improve this question
    
Have you tried booting in Safe Mode? support.apple.com/kb/HT1455 –  Ryan Sharp Jan 27 '11 at 23:35
add comment

4 Answers

There's a free app called AppleJack that's good for ths kind of thing. If you don't have that, Apple Hardware Test may help.

share|improve this answer
    
Thanks @nathan, I'll check those out –  wajiw Jan 27 '11 at 23:06
    
+1 AHT. Hold D while booting your iMac to get into that. –  Harv Jan 28 '11 at 0:46
add comment

Try Verbose Boot - Command-V while starting, it will show you what the systme is doing as it starts up instead of a pretty gray face. If you get anything like "disk0s2: I/O Error" you're looking at a failing hard drive. Go to the nearest Genius Bar or other AASP. If you get hung up with some other errors, try re-installing the system from the Snow Leopard DVD.

share|improve this answer
add comment

When you ran a disk verify (which, IIRC, you must do before you can run a disk repair,) what were the errors that came up? You may be looking at a dying hard-drive. Try to use the iMac as little as possible until we (or someone at Apple/with an Apple certification) can help you figure out what's going on.

share|improve this answer
add comment

If it'll boot into single-user mode (hold Cmd-S while booting) try repairing it with fsck (filesystem consistency check and interactive repair) -- "help fsck" when you get the prompt. Work carefully; you'll have root permissions!

share|improve this answer
    
This is what Disk Utility does. Shouldn't make any difference doing this or using the GUI utility on the install disc. –  Nathan Greenstein Jan 27 '11 at 23:47
    
Most advice I read concerning fsck suggests that it's a poor idea to run it on a mounted file system because the FS can change underneath it, and that it won't fix any errors in that case. Thus, my recommendation for running it in single-user mode. See hintsforums.macworld.com/archive/index.php/t-2666.html , for example; or Google 'fsck multi-user' for others. –  JRobert Mar 12 '11 at 17:15
    
That's why I said 'on the install disc'. That way, you've booted with the CD and the HDD's fs isn't in the way. –  Nathan Greenstein Mar 12 '11 at 17:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.