Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to copy some files from my local drive to a SMB share I have set up on my home network using Terminal, but I keep getting this error:

fchmod failed: Permission denied 

The share is set up on a Freenas server and the folder permissions is set to 777. I can copy the files ok with Finder so I don't know why its not working in Terminal.

share|improve this question
Could you copy and paste the relevant commands and error messages into your question ? Also the result of ls -l on the source and destination directories ? – Paul R Nov 13 '12 at 16:13
I had to send the laptop back. Hopefully I will have a replacement next week. I will post back then – johnmcp Nov 13 '12 at 20:08

1 Answer 1

The problem here is that terminal is trying to write Unix style permissions to the CIFS share during the copy operation.

When you perform "cp" via terminal the data will transfer but the fchmod command will fail as the "core CIFS protocol does not provide unix ownership information or mode for files and directories".

A few solutions:

  • Mount the share via command line and engage the noperm option to ignore permission errors.

    mount_smbfs -o noperm "//DOMAIN;" /Volumes/blah
  • Alternatively you can use rsync to copy files (without the -a flag)

    rsync -rl source destination.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.