Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How can I access Windows PCs from my Mac, and vice-versa, on the same network. I need to transfer files back and forth, and I can't seem to figure out how to do it. I poked around the settings, added the MacBook to the workgroup and all, but the computers still can't see each other. Right now I'm using a USB HDD to shuffle files, but that is far from ideal...

share|improve this question

3 Answers 3

up vote 8 down vote accepted

Sharing must be enabled. To see the Mac from your PC's, enable File Sharing (System Preferences/Sharing/File Sharing). You will need to take the additional step of enabling Samba sharing, since PC's don't use Apple's File sharing Protocol (AFP). Do this by then clicking on options, and make sure "Share files and folders using SMB (Windows)" is checked. Turn it on for whichever accounts you wish to authorize.

In order to see PC shares from your Mac, the PC's must be on the same network, with sharing enabled. Share a folder or something. Is it XP, Vista, 7? If it's XP, disable Simple File Sharing. Do so by opening a folder, going to Tools->Options, and find it at the bottom of View. Then right-click a folder, go to Sharing and Security, and enable sharing.

If it still doesn't show up, you may have a network/firewall issue, and it warrants further help.. but try that to get you started.

share|improve this answer
1  
Alternate answer to "how to access windows PC's on the network": very carefully. :) –  Harv Jan 27 '11 at 0:16
    
almost worked. I can now see from my Windows 7 PC the MacBook, but it won't let me open it, with an error of "Can't find the network path", which is dumb because I can ping the MacBook and get the address... The MacBook however, still can't see any of the Windows PCs (all Windows 7). Do I need to add a WINS server entry? Can it be the router? –  Alex Jan 27 '11 at 0:52

Harv's answer is spot on for getting Samba sharing enabled. I am contributing my personal experience with this particular issue.

I am able to get sharing to work by setting the IP explicitly for the machine I wanted to connect to with Connect to Server via Finder. For instance, smb://192.168.0.100/Shared. This worked well enough for my needs.

On the other hand, I was able to see the Mac in the Network view on the Windows machine and access its shares. Just for whatever reason the Mac can't see any other devices on the network via Network in Finder.

share|improve this answer
    
Actually, I was accessing the MacBook from the PC using the wrong syntax (forgot `\`). So, I can access from the PC to the MacBook fine now. I tried the 'Connect to Server' you showed and it should be working fine, if it hadn't been trying to go over 'afp://'... Is there a workaround for that? I already turned it off in Sharing. –  Alex Jan 27 '11 at 3:40
    
Do you mean 'afp://' is prepopulated in the Connect to Server box? I don't get that even with afp enabled... –  Ryan Wersal Jan 27 '11 at 4:20
1  
@Alex - Connecting from the Macbook to the PC.. when the dialog comes up for 'connect to server', make sure the path is smb://foo.bar/shareName, (where foo.bar is the hostname, or the IP, depending on your situation...). Windows doesn't use AFP, whereas the Mac does by default. –  Harv Jan 27 '11 at 6:21
    
@Harv, got it all worked out, thanks for the help! –  Alex Jan 27 '11 at 19:53
    
@Alex - No problem. Glad we could help. :) –  Harv Jan 28 '11 at 0:44

If the files are < 2.25 GB, an alternative with almost zero setup effort would be to use DropBox. If you are feeling friendly and want 250 MB extra, you can use this link.

When DropBox detects both computers are on the same local network, it will transfer directly between them, not requiring routing the files through their server (although the files will eventually end up there).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.