Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to turn on spotlight for my NAS drive. I have it mounted in OSX 10.8.2 as the following:

 /Volumes/Trogdor (smbfs, nodev, nosuid, mounted by soltrain)

mdutil returns the following:

mdutil -as (removed non relevent parts)
/Volumes/Trogdor:
    Indexing and searching disabled.

When I try to enable it I get the following:

Noahs-MacBook-Air:~ soltrain$ mdutil -i on /Volumes/Trogdor/
                              /Volumes/Trogdor:
                                  Indexing and searching disabled.

I've looked for a .metadata_never_index file on /Volumes/Trogdor/ but do not see any such file. I've also added/removed the volume from the privacy preferences in the spotlight pref panel with no effect. Any ideas? I'd rather not use a separate util if spotlight should be working.

share|improve this question

2 Answers 2

You need to manually enable spotlight on smb mounted volumes in Mountain Lion.

Try 'mdutil -as /Volumes/Trogdor' - you should win indexing :)

share|improve this answer
    
Gah. ignore me - sorry! –  Huwge Dec 2 '12 at 13:26
5  
Did you mean to delete this answer entirely or how are we supposed to interpret the comment? –  bmike Dec 2 '12 at 13:38

try mdutil -i on /Volumes/Trogdor

share|improve this answer
    
Please see my original question for the result of this command –  Noah Li Aug 2 '13 at 9:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.