Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My OSX Mountain Lion will no longer atart up. After the logon screen it spins forever (the Apple logon is replaced by an error sign).

When I run in single user mode I get a "still waiting for root device" that repeats every few seconds.

I suspect the problem is with core storage. Although I have encrypted the osx partition, the system can't find it (from recovery):

diskutil corestorage list
No corestorage logical volume groups found. 

fsck_cs will however report a corestorage:

** Checking volume.
   Content Hint for disk0s2 is not Apple_CoreStorage
** disk0s2: Scan for Volume Headers
** disk0s2: Scan for Disk Labels
** Logical Volume Group D4B301AF-3633-418B-980D-4CADB2DA6B0B on 1 device
** disk0s2: Scan for Metadata Volume
** Logical Volume Group has a 16 MB Metadata Volume with double redundancy
** Start scanning metadata for a valid checkpoint
** Load and verify Segment Headers
** Load and verify Checkpoint Payload
** Load and verify Transaction Segment
** Load and verify Transaction Segment
** Incorporate 1 newer non-checkpoint transaction
** Load and verify Virtual Address Table
** Load and verify Segment Usage Table
** Load and verify Metadata Superblock
** Load and verify Logical Volumes B-Trees
** Logical Volume Group contains 1 Logical Volume
** Load and verify BE7E7CD3-AB97-45F3-AC3C-B4AE8D73E22F
** Load and verify C418ACC5-E2D4-4EDE-84D7-2366A261A08E
** Load and verify Freespace Summary
** Load and verify Block Accounting
** Newest transaction commit checkpoint is valid
** Load and verify Segment Cleaning
** The volume D4B301AF-3633-418B-980D-4CADB2DA6B0B appears to be OK.

Any ideas on how I can repair this?

Or at least mount it to get at a few files?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I was finally able to fix the problem:

  • boot into recovery
  • unmount all volumes (otherwise gpt will complain that the resource is busy)
  • use gpt to remove the partition (it had the HFS instead of the CoreStorage type)
  • also delete the partition from the MBR with fdisk (otherwise gpt will not allow you to add the partition).
  • finally use gpt to add the partition with the same values but as core storage (type 53746F72-6167-11AA-AA11-00306543ECAC)

Afterwards diskutil cs list showed the volumes again - disk utility repair did the rest. No data lost :)

share|improve this answer
    
Can you elaborate on how this worked? I have an image of a CoreStorage partition that I can't figure out how to recover. It was created using dd from a hard drive that was about to fail. The dd was run on the physical volume that underpinned the CoreStorage volume. –  Matthew Strax-Haber Oct 2 at 16:46
    
sorry, that was 2 years ago and about the only time I used that method. take a look at man gpt and man fdisk. –  hcris Oct 2 at 21:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.