Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to install aquaterm via macports. I run

 sudo port install aquaterm

This gives back an error:

 --->  Building aquaterm
 Error: org.macports.build for port aquaterm returned: command execution failed
 Please see the log file for port aquaterm for details:      
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/main.log
 To report a bug, follow the instructions in the guide: http://guide.macports.org/#project.tickets
 Error: Processing of port aquaterm failed

In the log file I see:

:info:build You have not agreed to the Xcode license agreements, please run
'xcodebuild -license' (for user-level acceptance) or 'sudo xcodebuild -license'
 (for system-wide acceptance) from within a Terminal window to review and agree 
to the Xcode license agreements.

However, when I run

sudo xcodebuild -license

I receive this message:

xcodebuild: error: invalid option '-license'

I did not find anything useful on this error on internet. Did anybody see this error before? Do I need to run xcodebuild in a specific directory?

I am running Mac Os X 10.8.2 and Xcode 4.5.1.

Thanks!

share|improve this question
    
Which version of Xcode is installed? –  patrix Oct 31 '12 at 18:35
    
Thanks @patrix for your interest. I am running Mac Os X 10.8.2 and Xcode 4.5.1. –  Enzo Oct 31 '12 at 18:38
    
Did you install the command line utilities from within Xcode? –  patrix Oct 31 '12 at 19:07
    
@patrix I am not sure how I installed them. How can I reinstall them from within Xcode? –  Enzo Nov 9 '12 at 19:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.