Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

It looks like the Apple Mail application is not using the system's proxy settings. I have configured the proxy in the network system preferences, and all of my web browsers (Safari, Chrome, Firefox) are using these settings, but Mail.app doesn't seem to.

I've tried to connect to an IMAP server, but the request always times out. When I check using netstat, I can see that Mail.app is trying to directly connect to the IMAP server without going through the proxy.

Is there a way to force Mail.app to go through the proxy?

This is on Snow Leopard.

share|improve this question
1  
The proxy is "just" a web proxy (for port 80), Mail uses different ports. –  patrix Oct 31 '12 at 13:14
    
Yes, that seems to be the case - but is there a way to define a proxy for Mail.app? Without a way to specify a proxy, Mail looks completely useless if you have to work through a proxy/corporate firewall. –  nwinkler Oct 31 '12 at 13:19
    
Does apple.stackexchange.com/questions/54557/… help? –  patrix Oct 31 '12 at 13:23
add comment

2 Answers

Use ProxyCap. Add there a "redirect" rule for the Mail.app bundle.

Note that a regular HTTP proxy will not work for Mail.app. You will need one of the following: SOCKS, SSH.

share|improve this answer
add comment

If you have ssh access to the machine you want to be a proxy, you can also do ssh -D 12345 proxy.server.com and configure your computer to use SOCKS proxy, using localhost and 12345 as proxy host and ports in the settings, accordingly. Obviously you can specify a different port, but it's best to keep it higher than 1024.

The -D option for ssh enables a built in SOCKS proxy, which you can use then to send all other traffic through. Please bear in mind that the traffic from terminal (telnet, ssh) will NOT go through the SOCKS proxy regardless of how you configure your network settings.

I would have uploaded relevant screenshots, but unfortunately the internet connection I use here is very slow - 256kbps satellite link, shared by around 50 people and a host of experiments!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.