Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just upgraded the RAM in my MacBook Pro (15" 2 GHz Intel Core i7 - early 2011 model) from two 2gb modules to two 4gb modules. Started up just fine and ran great for about 10 minutes. Then the screen froze and the computer started beeping. After some google searches I found that it is caused by either a) bad RAM or b) the RAM is inserted incorrectly. My guess is that the computer shouldn't start if it's bad RAM. Others online report their computers beeping on startup. I tried repositioning the RAM to make sure it's in tight. The same thing happened.

The computer recognizes the RAM - it shows up in About My Mac. The RAM is Corsair 8gb 1333 MHz DDR3.

What's going on?

share|improve this question
add comment

4 Answers

How many beeps are you hearing. A discussion thread on Apple's site suggests that 3 beeps is a sign of a bad memory bank. So maybe the connection is solid enough to display in About this Mac but "loose" enough for the MBP to see properly use the RAM? Trying to think of a better way to phrase that last bit.

share|improve this answer
    
I am hearing three beeps. I hope that's the answer because I don't want to have to return the RAM. But, I did open the computer and reposition the RAM very firmly in the slots, to no avail. –  ethayne Oct 31 '12 at 14:06
    
Is there a plate over where you install the RAM? My father had something similar on his iMac: three beeps after installing RAM. In that case, the plate wasn't screwed on tightly enough or maybe it was slightly misaligned. –  Brooks Seymore Oct 31 '12 at 17:50
    
No, the modules are exposed. –  ethayne Oct 31 '12 at 22:07
    
Could there be some dust or particles where the RAM sits? Might be worth pulling out the chips and blasting it with some compressed air? –  Brooks Seymore Nov 1 '12 at 21:56
    
Possibly, but I put the original RAM back in and everything works just fine. I think the RAM must be bad. –  ethayne Nov 1 '12 at 23:39
add comment

I'm sure there is an Apple support page about the beeps, each of which means something, they're not to be ignored. But I wouldn't be so sure about your assumptions--my guess is, you've got bad/questionable RAM. Or, alternately, more RAM than the machine specifies--or a kind whose specs are slightly off.

You could try one chip at a time, also switching slots.

share|improve this answer
    
Thanks. I may try that. I did some research beforehand and I bought RAM that was recommended specifically for my computer, and the computer supports up to 8gb, so I don't think that's the problem. –  ethayne Oct 31 '12 at 14:15
add comment

i also installed corsair memory into a early 2011 Mac Pro.ran for 10 minutes and began beeping 3 x.i removed it and ran 1 slot with no problems for a day. switched postions and added the other one. ran 12 hours under heavy applications,then crashed. it corrupts my aperture files i won't do it it again waiting to here from corsair .i'm afraid i'll be eating the memory though.

share|improve this answer
add comment

Three tones in a series that repeats is universally a "Memory Problem" detected during power-on-self-test (POST).

Here are two support articles covering the general test and iMac codes (which match most recent Mac model POST firmware.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.