Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use both Chinese (pinyin) and Japanese (romaji) input and am used to having them mapped to a standard US keyboard layout. However my regional setting is Switzerland since I'm studying here and “internet services may vary according to region”. Strangely, the Japanese input uses the US keyboard layout, but Chinese uses a European layout (not sure what, but z and y are switched). (Irrelevant to problem).

My inputs are, in this order:

English (US) German Japanese (Kotoeri) Chinese

As Tom pointed out, in Kotoeri's preferences the layout can be defined. The Chinese input however uses the last layout of a Latin input, in this case German.

There also doesn't seem to be an option to customise the order of these inputs. My workaround is to cycle backwards, but this obviously is a special case. If anyone has a better solution it would be appreciated.

share|improve this question
    
Just to clarify, when you have your region set to United States, your z and y keys are according to the standard US QWERTY keyboard? Are they also set to that mapping with your region set to Switzerland, or are they reversed? When you switch to Chinese with the US region set, those keys are mapped differently than when you switch to Chinese with Switzerland set as the region? –  Jonathan Oct 30 '12 at 16:38
    
Do you really need the German layout active? See my comment further down, there are easier ways to make accents. –  Tom Gewecke Nov 2 '12 at 13:43
    
@TomGewecke: I wasn't aware of those shortcuts, thanks. I'll try to get used to this workaround, would be nice to be able to set the layout permanently if it was possible. –  lifesayko Nov 8 '12 at 8:30

2 Answers 2

up vote 2 down vote accepted

You set the Latin keyboard layout for Japanese input in the Kotoeri Preferences. For Chinese, the IM normally uses the last Latin keyboard layout that you have used.

Settings you make in the system preferences/language & text/language or formats tab are irrelevant for the keyboard layout. Only the input sources tab affects that (and Kotoeri preferences when that is chosen as an input source).

share|improve this answer
    
I can confirm that Chinese uses the layout of the last Latin input used, whereas with Kotoeri the layout can be set in the Preferences. The issue arises for me because I also have German input (which I need occasionally for accents), and the order of the cycle: US-DE-JP-CN Do you know how this ordering could be changed (as I see, moving DE to last place would effectively solve the problem). Cycling backwards I guess would be one fix... Or even better, permanently set the Latin layout for Chinese? –  lifesayko Oct 31 '12 at 18:07
1  
Do you really need the German layout for accents? There are so many other ways to do that, like just holding down the vowel key to get the popup menu in 10.7 or later or using the standard mac option/alt shortcuts (option/alt + u, then o produces ö with the US layout). –  Tom Gewecke Nov 2 '12 at 13:19

If it's what I think you're asking, you can set this, but it's really hard to find. (It's not in the System Preferences app.)

On OS X in the Japanese interface, there's no "Romaji" input, but based on some screenshots I found, I'm assuming this is "英字" (eiji, i.e., halfwidth Latin characters). All of the Japanese input methods use a system called Kotoeri (ことえり). When a Kotoeri input method is selected, from the keyboard layout menubar menu in the top right, choose "環境設定を表示" ("Show Preferences", maybe?), which is indented a bit under a "Kotoeri" heading. (It disappears if you have a non-Kotoeri input method selected.) There, you can choose a base keyboard input method for Kotoeri to use.

Alternatively, there's nothing special about the (half-width) Romaji / 英字 characters: they're just Latin characters. I don't even have this layout enabled. When I want to type Romaji, I just use my (western) layout. I can't tell what benefit there might be to using Kotoeri for this.

Sadly, I don't know anything about Chinese, so you're on your own there, but I suspect it has a similarly well-hidden setting. :-) I enabled the Chinese keyboard layouts here, and got some extra menuitems in the keyboard layout menu, but nothing that looked quite the same as the Japanese settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.