Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Microsoft Natural Ergonomic Keyboard connected to my 2011 MacBook Pro.

The keyboard's normal keys (letters, etc.) always work fine; however, there is a problem with the various function keys.

Basically, they don't work until I go to System Preferences -> Microsoft Keyboard. Once I go to that prefpane, everything starts working again.

It seems to somewhat randomly stop working, requiring me to go to System Preferences again to make it work.

How can I fix this? It seems like a daemon/driver that's supposed to make the keys work is crashing, but I searched for microsoft with no luck.

share|improve this question

2 Answers 2

up vote 8 down vote accepted

The reason for this is that Microsoft Keyboard Helper is somehow not being added to the Login Items by the keyboard's driver installer. However, the helper is contained inside the Microsoft Keyboard Preference Pane, so it is being run when you open it, and thus restores the full functionality of the keyboard.

The simple solution is this:

  1. Open System Preferences;
  2. Go to Users & Groups > {your user} > Login Items;
  3. Click + icon under the Login Items list;
  4. When Finder window opens, press + + G;
  5. When a form appears, paste this into it: /Library/PreferencePanes/Microsoft Keyboard.prefPane/Contents/Resources/;
  6. Select the file MicrosoftKeyboardHelper, and press Add;

That's it. The keyboard should now retain its function keys' functionality after the restart.

share|improve this answer
This is a devilishly subtle issue because the first thing you do to try to fix it (opening the Preference Panel) does indeed fix it until you restart or log out. I think I've probably wasted hours on this over the years, so many thanks for supplying the, obvious in hindsight, solution. – Perry Aug 20 at 18:05

I also have the Microsoft Natural Ergonomic Keyboard. In my case the simple solution was to press the F Lock key at the far right of the function row (left of the Print Screen button). I didn't realize the button even existed until now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.