Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Back in the summer I bought an external hard drive for my MacBook Pro because I make videos on YouTube and they obviously take up a lot of space on my computer. The first couple of times I plugged the new drive in, moved the videos/files to it and deleted them from my computer I got a tonne of storage space back (as of course was expected).

But recently, when I went to move more videos to clear up space, I didn’t get the amount of space I expected back. In fact, the space I got back from deleting movies went into the “backup” part of my storage and the same goes for random files. Why is this happening? I don’t use Time Machine or anything. How can I prevent this from happening because it’s driving me nuts and limiting my current movie imports.

share|improve this question
    
Hello, and welcome to Ask Different! To help people help you, you should provide as many details on your problem while striving to keep your question concise. In this case, you might want to explain what you mean by the “backup part” of your storage (this last one being your internal HD, I suppose?), what “random files” you find there, and what “or anything” you are not using. –  kopischke Oct 28 '12 at 21:15
add comment

2 Answers

You might need to disable local time machine backups by the sound of it.

 sudo tmutil disablelocal

Or you can just ignore that space that's allocated as backups and once the drive fills to 80%, the system automatically prunes old backups.

share|improve this answer
    
It actually seems to have fixed itself, strangely enough. it dropped from 121GB to 12... and it did that before I started to clean out other useless crap from my laptop. But how would I go about disabling local time machine? :) –  Sydnee Oct 27 '12 at 21:27
    
Here's a page full of info about local snapshots. But seriously, you don't need to disable it. They surrender their space automatically. I don't know why the Storage page doesn't make this more explicit. The amount shown in Finder does exclude them, though - that's the Free number you should pay attention to. –  gabedwrds Oct 28 '12 at 4:12
add comment

Open System Preferences, under the Apple Menu, and the Time Machine preference pane.

Turn it to Off.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.