Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I don't really know if it is like that for everyone or if there are some bootcamp driver issues on my machine, but:

Every time I plug in headphones, a mini-stereoplug or a optical mini-TosLink cable and want the sound to be played via the attached device, I have to open the output devices settings and choose the desired one and "set it to default". (windows 7 64bit, bootcamp w/ most recent drivers)
Is there some possibility to have an app do this automatically on (un-)plugging the cables or at least something that changes audio output device via a hotkey/combination?
Or should it change automatically out of the box and something is nessed up with my bootcamp drivers?

macbook pro 15", i7 late 2011

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

No, Windows 7 does not automatically switch audio devices. Nor do bootcamp drivers allow this to happen on Apple devices running Windows.

A quick search on the web brings up multiple articles about how to change the audio device more quickly (e.g., via a hokey, or small apps). Here is one toolbar app found:

http://hardforum.com/showthread.php?t=1656534

share|improve this answer
    
thanks, thought the usual windows tools wouldn't work for bootcamp driver stuff. –  blub Oct 27 '12 at 18:51
1  
I beg to differ. For the past 3 years I've been running Windows 7 on my MacBook Pro and it has always switched audio device automatically when I have plugged in headphones. Although for some reason mines has stopped doing so and I am surprised at the number of people having this problem as it has always worked fine for me prior to this. I should also add that my problem is specific to flash player as it doesn't use the built-in speakers when there are no headphones plugged in but other applications work fine. –  ctor Nov 20 '12 at 10:58
add comment
  1. Activate the 'Mute the rear output device when a front headphone plugged in' under the advanced settings menu.
  2. Click on the Folder Icon next to Analog.
  3. Click on the 'Disable Front Panel Jack Detection' button.

I've got both green connectors set to headphone.

It has always worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.