Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Homebrew (to then install RVM, then Octopress).

Homebrew is installed but when I run brew doctor I get the message:

Consider amending your PATH so that /usr/local/bin occurs before /usr/bin in your PATH.

I have changed my ~/.bash_profile to export PATH="/usr/local/bin:/usr/local/sbin:~/bin:$PATH".

~/.bashrc is empty.

etc/paths has

/usr/local/bin
/usr/local/sbin
/usr/bin
/bin
/usr/sbin
/sbin

echo $PATH states /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/Users/deadlyhifi/.rvm/bin

I tried installing RVM previously but had all kinds of problems with the compiler not being correct since I have Xcode 4.5.1 installed - I uninstalled RVM and am now trying again. My $PATH has reference to the RVM but I can't for the life in me find the file that contains that path.

Can anyone shed any light on the subject?

Edit:

The etc/profile contains:

# System-wide .profile for sh(1)

if [ -x /usr/libexec/path_helper ]; then
eval `/usr/libexec/path_helper -s`
fi

if [ "${BASH-no}" != "no" ]; then
[ -r /etc/bashrc ] && . /etc/bashrc
fi
share|improve this question
    
Can you please copy and past your entire ~/.bash_profile and ~/.profile. Also, I assume that the paths in \etc\paths are not on the same line, right? – Maverik Oct 26 '12 at 9:48
    
I've added the profile data, and etc/paths are on separate lines. – deadlyhifi Oct 26 '12 at 11:11
    
Please copy and paste also ~/.profile if exist – Maverik Oct 26 '12 at 11:42
1  
I've figured it out. I've got Oh My ZSH installed. That's created ~/.zshrc. This is where the $PATH is defined. I've edited that and now my system is raring to brew. I'd have never found that if I wasn't searching through all the .files. – deadlyhifi Oct 26 '12 at 12:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.