Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a annoying problem since I updated my iPhone 4S to iOS 6:

when I sent a message to someone and I get the reply, the reply is not added to the normal conversation but a Group MMS will be created, with the replier and me as a recipient.

So here are the two annoying things about it:

  1. the whole conversation overview is split into two conversations, one conversation only with my messages and the replier's Group MMS with his/her reply. No overview about the whole conversation at all

  2. Every time I reply in that Group MMS conversation, the iPhone also sends me an own message, having me as a recipient. That is just annoying because then I have my message twice and I have to delete the extra message in order to keep the conversation clean and of course the phone rings and vibrates when I get my own message.

I cannot merge the two conversations and I didn't find an option to turn Group Messages off or to delete me as a recipient. And it happens to every message sent, so probably not an iMessage bug.

As a carrier I have SoftBank from Japan. In Japan they use e-mail addresses instead of numbers, maybe this is causing the whole thing. But I doubt it a bit because before the update everything went fine.

Can somebody help me?

share|improve this question
add comment

1 Answer

I had the same problem and I, too, was frustrated as there seems to be no available information on this topic. Not to mention its annoying as hell.

Anyway, this worked for me and it might work for you too.

  1. Open Settings
  2. Tap "Messages" settings
  3. Scroll down to the MMS Email Address.
  4. Make sure to enter the MMS Email Address EXACTLY as it is specified with SoftBank. You can find that information if you login to MySoftbank. https://my.softbank.jp/msb/d/top

I actually had this problem when I bought a new iPhone 5. The girl at the shop who set up my phone unbeknownst to me added a space at the end of the MMS email address. Ah well.

Hope this works!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.