Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I got a mid 2011 MacBook Air 13.6" and its keyboard and mouse freezes very often after I leave it in sleep mode for some time and it wakes up. Only the power key and the lid detector are still responsive. It’s also possible to connect to it via VNC or SSH.

I had a look into the error logs but I couldn’t find anything suspicious. I found out that the System Preferences app does not start anymore and all the OSX related menu bar icons seem to freeze too (Bluetooth, WiFi, Battery icons).

Freezes after sleep mode seem to be a common problem but I couldn’t find any case yet that is like mine (others have a grey screen, no WiFi connectivity, still mouse responsiveness or the keyboard responsiveness comes back after a while – issues I don’t have).

Edit:
- Also the iSight Camera is not responsive anymore.
- Notification Center and Hibernation mode do not seem to be the problem (I tested both).

share|improve this question
    
I’m not sure why but the problem seems to be solved. –  mcb Dec 20 '12 at 0:53
add comment

1 Answer 1

I had the same issue on my Macbook Air and Mountain Lion.

The quickest way to solve this is to disable the login screen or the "ask for password" setting.

If you're worried about privacy, do the following:

  • Reset PRAM
  • Reset SMC

If it still doesn't work, disable deep sleep mode (hibernate) by doing this:

sudo pmset -a hibernatemode 0

Note that doing the above will only put your computer on battery sleep and this will affect battery life when you're not using your mac.

share|improve this answer
    
For me, the symptoms are gone for a while now, but I have no clue why. I think, I still had problems after updating to 10.8.2, so that was not the cure. I also tried to disable deep sleep mode and resetting PRAM and SMC, but it didn’t help. Back then I didn’t have the login window enabled, but I have now, so that does not seem to be the solution either. Thanks for your response anyway. –  mcb Jan 27 '13 at 14:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.