Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The SystemUIServer process is taking 30% of my CPU. Searching around reveals a Snow Leopard daylight savings bug which is solved by removing the clock from the menubar. I am on Lion and I have tried this without success. Any ideas on how to fix this?

share|improve this question
2  
I can't offer a concrete guess as to why your UI has constant work to do, but it's usually a third party menu item stuck in a loop. If you want to debug this, you could run sysdiagnose SystemUIServer and file a bug with Apple. Often you can look over the reports to see what the process is doing - since you are also on Stack Overflow this might be something you have the knowledge to look over the script and results and figure a reason why CPU is high. –  bmike Jan 7 '13 at 18:07
add comment

4 Answers

up vote 5 down vote accepted

Same problem here. The problem is caused by a third-party widget that uses the internet. For me, dropbox was the problem. If dropbox is updating my files, systemuiserver keeps using a high amount of CPU .. the only solution is to force quit it (using terminal or activity monitor) or disabling the third-party widget.

share|improve this answer
add comment

Looks like there are actually a couple ways to solve this.

I have been having the same problem, and today I also noticed my clock hadn't been showing the correct time in about 2 hours, and when I hover over the clock I get the spinning beach ball.

So I found from this article that you can simply kill the SystemUIServer process and it will just restart itself and all should be well again.

In order to kill the SystemUIServer process, you can simply open Activity Monitor, Filter by Process Name or %CPU (as it will likely be the highest CPU user), then select "SystemUIServer", and choose "Quit Process" from the options at the top of the window (button that looks like a stop sign).

Once you kill the process, OS X will simply re-initiate the process, and you should be back on track. However this seems to be only a temporary solution, and you may encounter it again.

So for a more permanent solution (if you are not afraid to venture into terminal land), try the process outlined in this article, which was provided by Joshua Taylor where you add a cron job to OS X that restarts SystemUIServer at the beginning of every other hour (automating the solution above to this problem):

Open your terminal (/Applications/Utilities/Terminal.app).

Type:

crontab -e

..and hit enter.

Hit the letter "a" on your keyboard.

Enter the following, using tabs for the large separations:

0 */2 * * * killall SystemUIServer

Hit the escape key on your keyboard.

Type:

:wq

..(that's colon, w then q) and hit enter.

Close Terminal.app.

share|improve this answer
3  
This seems like treating one of the symptoms, not anything about what causes this in the first place. Imagine a car that stalls. You've showing how to automatically restart the engine, but not actually fixing the issue. –  bmike Jan 7 '13 at 20:14
add comment

This would terminate the process only if the CPU time is over 5 minutes:

*/15 * * * * [[ "$(ps -e | grep SystemUIServer | awk '{print $3}')" > 5:00.00 ]] && killall -kill SystemUIServer

If you don't know how to use vi, you can modify the crontab with EDITOR=nano crontab -e.

share|improve this answer
3  
This is a decent automated recovery method - but doesn't explain how to fix anything. I suppose you are implying that there is a memory or resource leak and periodic pruning is needed, but if the process writes to any files, summarily killing it can also escalate the problem. –  bmike Jan 7 '13 at 20:16
add comment

I've recently had the same problem on a Mac Pro running system 10.7.5 with DropBox installed. Updating to the current version of DropBox (2.6.2) has helped considerably, but not completely. Instead of getting a system slow down with a spinning rainbow wheel and SystemUIServer reporting 98% cpu usage multiple (annoying) times per day, it is now down to twice today.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.