Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a mid-2010 MBP with Mountain Lion. I performed a format and re-install (2 times). The first and only thing I installed was XCode (most recent version is 4.5.1). I have tried to run some of my projects, also just a plain blank project fresh after the create menu (all target iOS 6). Compilation is fine, but when I try to run on iPad/iPhone simulator, as soon as the iOS simulator is launching the screen goes black and the system restarts. Any ideas on how I could fix this? From Googling I've not seen anyone with quite the same issue, but have tried things such as deleting plist files, changing the debugger used, using no debugger, but it still crashes.

EDIT
It turned out to be a fault with the graphics card. I am getting it replaced.

share|improve this question
    
Post logs of the crash from Console. –  duci9y Oct 18 '12 at 14:23
    
Thank you for your response. I will post the crash log when I get home in 3 hours. –  bean Oct 18 '12 at 14:25
    
I wouldn't be surprised if this is evidence of a physical problem with the machine –  JoshRagem Oct 18 '12 at 14:40
    
Thanks for the heads up JoshRagem. I have tried to run the apple hardware tests using "D" or "Command-D" on restart but I think maybe my MBP doesn't have this feature (mid-2010 with i5?). I don't have the install disks so I was trying the internet before I take it into a Mac shop! –  bean Oct 18 '12 at 14:53
    
Thanks for the advice both. Unfortunately now my mbp is in a reboot loop! I am going to have to get this looked at. –  bean Oct 18 '12 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.