Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my Retina MacBook Pro, the Python IDLE development environment has blurry, non-retina text.

Is there a way I can make the text retina?

IDLE:

Screenshot of IDLE

share|improve this question
    
Which app is actually experiencing poor resolution? Is there an actual application called "Python"? –  Dan J Oct 15 '12 at 22:29
    
Yes .......... python.org –  Render Oct 15 '12 at 22:57
    
What @DanJ is asking is that in the terminal, where python is often run, everything should look fine, because the Terminal app is responsible for rendering text, and is retina compatible. Using python, ruby, perl, anything from the terminal should not make a difference. Are you talking about a Python IDE, or third party terminal app? How about a screenshot demonstrating your problem? –  Jason Salaz Oct 15 '12 at 22:58
    
Python IDLE. Terminal does not print characters in colors unfortunately, otherwise I would use it rather than IDLE. Ill post a pic in a bit –  Render Oct 15 '12 at 22:59
    
What do you mean, Terminal doesn't print color characters? Are you saying you want syntax highlighting? Or colored output? –  segiddins Oct 16 '12 at 0:28
add comment

3 Answers

up vote 3 down vote accepted

At the moment this isn't likely to be fixable, unless you're fairly comfortable with OS X development and want to rewrite parts of the underlying GUI library.

According to this bug report on Python.org, it's an issue with the TkInter GUI library, which IDLE apparently makes use of. TkInter in turn is based on Tk, which is a cross-platform GUI toolkit, which means it almost certainly doesn't use the standard OS X text renderer, which is the only way to get "free" Retina text.

As an alternative, perhaps look at ways to make the default python shell or IPython running in Terminal more useful to you?

share|improve this answer
add comment

I'd say segiddins has it almost right, with a couple of slight adjustments that made that solution work perfectly for me:

  1. Copy IDLE.app to the desktop.
  2. Right-click the copied IDLE.app and select Show Package Contents.
  3. Open Contents/info.plist.
  4. Add the following two lines...

    <key>NSHighResolutionCapable</key>

    <true/>

    ...to the end of the plist file, but before the last two lines (</dict> </plist>).

  5. Save the plist.
  6. Replace the original IDLE.app with IDLE.app you just modified.
share|improve this answer
add comment
  1. Do Show Package Contents on the .app bundle.
  2. Open Contents/info.plist
  3. Add

    <key>NSHighResolutionCapable</key>

    <string>True</string>

    To the end of the plist file, but before the last two lines (</dict></plist>)

  4. Save the plist and launch the app!
share|improve this answer
    
That did not work :( –  Render Oct 16 '12 at 0:24
    
I guess it doesn't use a native text rendered then. –  segiddins Oct 16 '12 at 0:27
    
If I clicked on get-info, the option to open in Low Resolution is checked and locked !! –  Render Oct 16 '12 at 0:31
    
Is this after you made the change to the plist? –  segiddins Oct 16 '12 at 0:36
    
Before and after, the setting wont change –  Render Oct 16 '12 at 0:43
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.