Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So, I have a really weird problem with OS X 10.8.2. When I last configured it from scratch for the last time (the release of Mountain Lion), I was using the Apple keyboard. So, the default input method is the Belgian one.

But since, I bought another keyboard (Corsair K60). And as the keyboard layout is a bit different from classic Apple layout, I made my own with Ukelele.

It's been working really well since, I think, the last extra update pour 10.8.2. Since then, every time I switch to an app where you mainly type text (Notes, Sparrow, Twitter client, ... But not with Messages weirdly), OS X switch the input method to Belgian. And I can't switch back to my custom one.

I've already checked I've selected the option : "Use the same input method for all documents" is activated. So, I'm a bit stuck here. Any help ?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

If the custom keyboard layout is in ~/Library/Keyboard Layouts/, have you tried moving it to /Library/Keyboard Layouts/? That would normally prevent it from being switched to a default layout in password dialogs.

If you don't need the Belgian layout, there's also a hacky way to disable the default layouts.

share|improve this answer
    
Moving it to /Library/Keyboard Layouts/ seems to have solve the problem, thank you :) –  Axiol Oct 16 '12 at 10:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.