Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My OSX calendar app is configured to show all the birthdays of my contacts (they are displayed as this special calendar with the parcel icon in OSX). It seems that iOS (6, on iPhone 5) does that too but doesn't recognize that this is the same calendar as the one in OSX.

As a result, when I sync all my OSX calendars with my iPhone, suddenly there are two birthday calendars, one seems to come from OSX and does not have the parcel icon. That calendar is called "Birthdays" when viewed in iOS. The other one seems to be the one intrinsic to iOS and just like in OSX has special parcel icon.

I would have assumed that the two apps of the two OSes should figure out that this is basically the same calendar. To get rid of the double events in my calendar view in iOS I can uncheck that "Birthdays" calendar in iOS so that the events of this calendar are not displayed. But that calendar still gets synched from OSX and I can't uncheck the "Birthdays" calendar in the OSX iTunes sync settings because there this calendar is not listed.

My question is now, how do I get rid of the redundant calendar on the iPhone?

share|improve this question
1  
You should use iCloud to sync calendars, not iTunes. That’s very old school, especially when you have an iPhone 5. –  duci9y Oct 14 '12 at 15:54
1  
I am not comfortable with that. I'd like to keep personal data as offline as possible. I am german after all ;) –  bitbonk Oct 14 '12 at 16:06
    
Do you have Facebook sync enabled? I guess you don’t, because you are german, after all ;-) –  duci9y Oct 14 '12 at 17:01
    
Do you have another question, other than "Is that's the way it is supposed to work?" I'm just not sure the community can answer that question. –  KatieK Nov 12 '12 at 22:29
    
I have updated my question. –  bitbonk Nov 13 '12 at 10:52
add comment

1 Answer

On the mac, turn off Birthday calendars in the Calendar app preferences.

Disable Birthdays on OS X in the Calendar app

On the iOS device, unselect the check next to the programmatic calendar to suppress those entries. Short of jailbreaking the device and patching the Calendar app, you can't suppress the package calendar - just show or hide it.

Deselect the birthday check

Alternatively, you could purge all birthdays and anniversaries from all Contacts, but that seems too brute force to me when you can suppress each calendar with settings. Most that I have asked choose either the OS X calendar and suppress the iOS one or skip the OS X one and rely only on iOS for birthdays and anniversary entries.

share|improve this answer
    
Sad, that these are my only option, since both of them are flawed. –  bitbonk Nov 14 '12 at 18:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.