Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm basically using US keyboard as my default, but I also have enabled Czech (QWERTY), which has quite different layout for when I need those special characters.

The problem is, that in the past few days whenever I put focus in a password field in Google Chrome, it automatically switches from the US to Czech and I can't switch back, as it is grayed out.

alt text

But once I click out of the password field, I can change it back without any problems. What could possibly cause this? I'm using OS X 10.6.6 on Macbook Pro if that's of any relevance.

share|improve this question
    
In System Prefs > Lang & Text > Input Sources, do you have "Use same in all documents" or "Allow different for each document" selected? –  user588 Jan 24 '11 at 1:38
    
@mankoff: "Use the same one in all documents", but it does the same thing for both options. The problem is that I can't change it when the password field has focus, but once I click somewhere else, I can change it back. –  Jakub Arnold Jan 24 '11 at 2:01
    
While in Chrome, try a cmd+shift+delete, clear all passwords (for all amounts of time), cookie data, history, etc. Does this change anything? Does the same behavior happen in Safari? –  y3sh Jan 24 '11 at 19:57
    
I have the same problem right now, but in my case is small different. In my Mac was installed languages English and Russian. On focusing password field it changes to English from Russian. I think, it depends on system language, is that ? If you solved the problem help me too. please ! –  Ulugbek Komilovich Sep 23 '13 at 6:57
add comment

3 Answers 3

up vote 3 down vote accepted

I've had weird input-switching behavior before when the keyboard shortcut to switch input sources was the same as something else I was using, like Quicksilver. Try disabling or changing the relevant shortcuts in System Preferences (under Keyboard & Text Input).

UPDATE: Detailed instructions:

  • Open System Preferences
  • Open the Keyboard preference (under Hardware)
  • Select Keyboard and Text on the left
  • Find "Select the previous input source" in the box on the right and uncheck it. Its shortcut was probably set to Command-Space.
share|improve this answer
    
I didn't understand to your answer, because I am not expert at Mac. Can you explain again, but simplified it a bit. –  Ulugbek Komilovich Sep 23 '13 at 7:07
    
@UlugbekKomilovich - see my update. –  Mr. Jefferson Sep 23 '13 at 14:34
add comment

I'm having the same problem. I ended up just disabling the other two layouts and the problem stopped. Certainly frustrating, when you can't figure out why you're typing gibberish.

share|improve this answer
add comment

I could solve the issue by performing the following steps in Chrome:

  • disabling all chrome extensions
  • disable chrome extension developer mode
  • quit and restart chrome
  • enabling the previous settings again
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.