Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My iPhone4 periodically does not wake up from being locked. I have to wake it by holding the home and power buttons. This is happening a lot more frequently as of late than before. It has the latest OS. It seems quite a few people have the same problem. Does anyone know a solution to this problem? None that I found on the Apple forum seems to solve it.

share|improve this question
    
smae thing is happening to my iphone 3gs. with 4.2.1. I even tried restoring. Didnt help. –  eliben Jan 21 '11 at 6:48
    
Is it not waking up regardless of which button you press? I ask only because the home button on my iP4 went mushy and became almost useless. –  Philip Regan Jan 21 '11 at 19:21
    
@philip I'm pretty sure the buttons work perfectly. –  Jin Jan 21 '11 at 19:28
    
I don't know of a solution but I know of how I got in a similar situation, I was in a foreign city, data roaming and compass/location services (Map and Gowalla) were always running. One night it ended up like how you described when I tried to wake from using the Camera app. I am not sure how many apps/services running you can have open at once because I have curbed my use and watched for unused open apps since then and I have not had any problems. –  phwd Jan 27 '11 at 0:04
    
Like Philip, my home button does not work from a particular angle. Though the sleep button has always worked. I occasionally have this problem with an intensive process running, it just takes a while to wake. But if yours never wakes, different problem. Just saying, consider a minor hardware problem first. –  Jason Salaz Feb 21 '11 at 5:23

3 Answers 3

You could try going by the Apple Store to meet with a Genius (if there is one close enough to you). They have diagnostics they'll run for free to see if something weird is going on with your phone. Make an appointment online.

share|improve this answer

Have you tried restoring the iPhone via iTunes? You should sync the iPhone first to back up everything, then press the Restore button in the device management screen.

share|improve this answer
    
yes and it didn't help. as noted by other people too: forums.macrumors.com/showthread.php?t=958949 –  Jin Jan 21 '11 at 6:47
    
Taking in to your local Apple Store might be your next best option. –  Just Jake Jan 21 '11 at 6:51
    
@Jin Have you tried restoring the OS, but not restoring your data? –  Kyle Cronin Jan 21 '11 at 6:53
    
@kyle I tried that. looks like i may have to take it to the Apple store.. –  Jin Jan 21 '11 at 19:29

You could try to reset it: Settings > General > Reset > Reset All Settings. There might be some corrupted preferences somewhere.

Try to sync your iPhone and look into your ~/Library/iTunes/.../Logs (sorry, can't remember the exact path and I don't have a Mac right now).
And try to find out if there's a crash file that match the time of the issue. From there you'll be able to define if it's an app running in the background or iOS-related.

If none of the above, it might be hardware-related (maybe you're holding it wrong!) and will have to send it to an Apple Store.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.