Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Academy's wi-fi requires me to log in via a web-browser portal page before I have access to the internet. Safari on my iPhone doesn't save my username and password for it. Is there a way to manually force it to save them?

share|improve this question

check out this link to setup autofill name and passwords for safari on IOS.

And it totally is a matter of safari not remembering username/password.

It's a little hidden, but it's there, and thanks for asking a good question. The other answerers here must never have logged into a captive portal before or something.

share|improve this answer
This does not work as on the page I am using the user is never prompted to 'save password' so nothing is stored – adolf garlic Jan 4 at 16:22

Do you really need to log in using Safari?

Otherwise you go to 'System Preferences' > 'Wi-Fi' > Select the appropriate network > Log in > Deselect 'Ask To Join Networks' This way, your iPhone remembers this Wi-Fi network and your iPhone will automatically connect to this network when you're within the range of the academy Wi-Fi.

share|improve this answer
This answer is incorrect. The academy requires him to log in via a log-in page on the web browser like most other public hotspots. – George Spiceland May 20 '13 at 0:42

If this is a "captive portal" - a wifi network where you need to input your password into a form on a web page, or check a box agreeing to terms of use, then in my experience the iPhone will not remember the password.

share|improve this answer

It's not a matter of Safari not remembering the password, its a matter of the network requiring login based on the browser. Most captive walled gardens require it with every disconnect for security purposes.

share|improve this answer

I had this problem. Turns out I was in Private Browsing mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.