Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My iPhone is synced with my daughter's iPad. My iMessage texts are appearing on her iPad. We thought we had deleted them from the iPad but they appear to be still there in some sort of "history" section. The screen they are appearing in has no ability to delete; they are just sitting there. I would really like to delete these totally off my daughter's iPad. Any suggestions?

share|improve this question
    
When you say your two devices are "synced" together are you saying they share an Apple ID? Can you be more specific on what you mean by "synced?" –  Richard Oct 11 '12 at 10:43
    
If by "synced" you mean sharing the same Apple ID, then that's what's supposed to happen. You should, however, be able to go into Messages settings on the iPad and toggle off the phone number/email address that your iPhone's Messages uses (that way you can leave iMessage enabled on the iPad so she can still use it too). –  daGUY Oct 12 '12 at 18:32
add comment

1 Answer 1

Without seeing a screenshot of what, exactly, you're talking about, it's hard to give any really good advice.

That said, try this:

  1. Go to Settings
  2. Scroll down to Messages; set iMessage to OFF
  3. Back in Messages, go to the root screen (where you see all the different conversations listed); either click Edit and then swipe each conversation to delete as needed

This should get rid of all your messages, as well as prevent any further iMessages from being delivered to that device.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.