Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My main HDD is failing to boot. (Neither Normal, Safe mode nor Single User). I can only boot from Recovery Mode or DVD.

The scenario was the following:

  • Computer was asleep (lid down).
  • Lifted the lid then connected USB mouse.
  • Mouse nor trackpad nor keyboard responded.
  • Closed the lid, removed the USB mouse then opened the lid again.
  • Trackpad and keyboard responsive once again, but after trying to close some programs computer freezes.
  • Shutdown computer by pressing power button for 10 seconds.
  • At restart computer doesn't boot anymore.

When booting in verbose I noticed the following:

...
...
USBMSC Identifier (non-unique): 000000009833 0x5ac 0x8403 0x9833
disk0s2: I/O error.
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Write] [PBlkNum 2] [FSLogMsgID 61471212] [FSLogMsgOrder First]
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [FSLogMsgID 61471212] [FSLogMsgOrder Last]
jnl: unknown-dev: update_fs_block: failed to update block 2 (ret 5)
jnl: unknown-dev: journal_open: Error replaying the journal!
hfs: early jnl init: failed to open/create the journal (retval 0)
Kernel is LP64
com.apple.launchd                       1          com.apple.launchd
com.apple.launchd                       1          com.apple.launchd
***
com.apple.launchd                       1          com.apple.launchd
** /dev/rdisk0s2 (NO WRITE)
** Root file system
   Executing fsck_hfs (version diskdev_cmds-557-393)
jnl: disk0s2: replay_journal: from 13043200 to: 3971072 (joffset 0x15502000)
disk0s2: I/O error.
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Write] [PBlkNum 2] [LBlkNum 2] [FSLogMsgID 1396728806] [FSLogMsgOrder First]
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevMode devfs] [MountPth /dev] [Path /dev/disk0s2] [FSLogMsgID 1396728806] [FSLogMsgOrder Last]
jnl: disk0s2: update_fs_block: failed to update block 2 (ret 5)
jnl: disk0s2: journal_open: Error replaying the journal!
hfs_mount: journal_open == NULL; couldn't be opened on Macintosh HD
mount_hfs: Invalid argument
FIP USER Space POST: Integrity test failed!
BootCacheControl: could not unlink bootcache playlist /var/db/BootCache.playlist: 30 Read-only file system

After that it just gets stuck and never gets past that.

I booted in recovery mode then tried verify and repair disk with disk utilities put is seems to be OK. However Macintosh HD cannot be mounted.

Tried fsck_hfs from Recovery Mode terminal then got Macintosh HD cannot be repaired.

I'll want to know if there is anyway to rescue the system without reinstalling Mac OSX or at least a way to recover some files from the drive before reinstalling Mac OSX.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
  • there may be no way to rescue the system without reinstalling Mac OSX.
  • you might look into booting into single-user mode
  • that said, to the extent you care about un-backed up data on the hard drive, it might be wise to recover files BEFORE trying to reinstall/recover further
  • I have had good luck with DiskWarrior
  • You MAY be able to boot the broken disk/laptop in "Target Disk Mode" - if it has Firewire, if you have the cable, and if you have another Mac with Firewire to attach it to.
  • Failing that, you or a person with appropriate tools could remove the internal disk drive, attach it to a USB/SATA adapter of the appropriate kind and use DiskWarrior on it.

Good Luck!

share|improve this answer
    
I can't boot into single user mode. Tried DiskWarrior but it doesn't see the drive (what I managed to read is that if the volume cannot be mounted then DiskWarrior will not see it). I'll try with something like Data Rescue to recover my files. If that fails then I'll try removing the HDD and connect it to another computer because the other mac around is a white macbook with firewire 400 while mine is firewire 800, unless that doesn't matter to try the Target Disk Mode. Thanks –  jonathanwiesel Oct 11 '12 at 5:23
    
Sorry, my bad. I actually can boot into single user mode. I'll try to backup my data from there –  jonathanwiesel Oct 11 '12 at 5:33
    
As I recall, one can connect Firewire 400 to Firewire 800 if you have the right cable. It automatically will downgrade the speed to 400... –  Martin Haeberli Oct 12 '12 at 6:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.