Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My music/iTunes icon:

  • is present in the Dock
  • has gone from some panes of System Preferences.

This first screenshot is from the Spotlight pane, the icon is expected to the left of Music:

Spotlight preferences

The second shot is from the CDs & DVDs pane, the icon is expected to the left of Open iTunes:


How do I get these icons back?


  • MacBook Pro
  • Snow Leopard 10.6.8

What I tried:

  • reboot
  • login/logout
  • trash Finder and Dock preference files

Edit 1:

The output of the grep command suggested by Graham Perrin in the comments is as follows:

Laptop:~ myname$ system_profiler SPApplicationsDataType | grep  
      Location: /Applications/

In the Language & Text pane, three languages are present in the following order:

  • British English
  • Dutch
  • Russian

Logging into a fresh user account does not solve the issue. The same icon is missing in the same places.

Edit 2: Output for command /usr/bin/mdimport -L

Laptop:~ myname$ /usr/bin/mdimport -L 2012-10-24 11:12:32.307
mdimport[34295:903] Paths: id(501) (
    "/Library/Spotlight/Microsoft Office.mdimporter",
    "/Applications/OmniGraffle Professional",
    "/Applications/TeX Live",
    "/Library/Internet Plug-Ins/Google Earth Web Plug-in.plugin/Contents/MacOS/Google Earth for Earth.mdimporter",

Edit 3: Although the bounty has run out I still don't have a solution for this problem.

Edit 4:
I have been poking around and through the "Open Files and Ports" function of the Activity Monitor I think I found the location where the images are loaded from. The file is:


Unfortunately I cannot open this file. Does anyone know how to open the file to see if that is the place where the images are loaded from?
When I rename Artfile.bin almost no application starts.

Edit 5:

The Garageband application does show the iTunes icon: enter image description here

share|improve this question
Did you try changing the icon for iTunes in the past? – Gerry Oct 9 '12 at 9:56
No, I did not change the iTunes icon. – Saaru Lindestøkke Oct 9 '12 at 9:59
@GrahamPerrin I've added the requested information to my question. – Saaru Lindestøkke Oct 24 '12 at 2:39
I'll be tracking this. I have the exact same problem, and have even reinstalled 10.6.8 (for something else, not this) along the way, with no change. It started when I updated iTunes to 10.6.3 a few months ago. It took several tries to get the update to install, and when it finally went through - no icon in several places throughout the system. Good luck. – soxman Oct 24 '12 at 4:32
@soxman if you have the install.log files from that period, you could ask a separate (linked) question: Why did installations of iTunes 10.6.3 fail? – Graham Perrin Oct 24 '12 at 7:00

By reinstalling iTunes, did you completely trash the application and then copy it anew? Sometimes simply overwriting the existing installation doesn't do the trick.

share|improve this answer
I used TrashMe to remove iTunes. Then I downloaded iTunes again from the iTunes website. – Saaru Lindestøkke Oct 21 '12 at 10:55

Reinstall iTunes. The icons in the Spotlight preference window and other areas of OSX are mostly derived from the application bundle. It looks like the iTunes icon package has become corrupted. A reinstall will eliminate that as the reason.

share|improve this answer
Reinstalled iTunes, restarted, but nothing has changed. – Saaru Lindestøkke Oct 9 '12 at 13:10


sudo /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/ToolbarMusicFolderIcon.icns:

into to see if ToolbarMusicFolderIcon.ics exists.

If not, here is my copy. Download it and place it in:

share|improve this answer
That's not the right icon. On my system, both of the OP's missing icons are the iTunes app icon, not that one. – jmk Oct 21 '12 at 5:16
That's indeed not the icon I'm looking for, but I also don't have the file if I use the command in Terminal. – Saaru Lindestøkke Oct 21 '12 at 10:55
Oh :( sorry about that then – AMomchilov Oct 22 '12 at 15:44
That's also the wrong command. The icns file is not executable, so it will fail on any system. What you probably mean is sudo ls .... – guwac Oct 24 '12 at 10:44
Actually it's not really a command, that's the point.. it'll either say if it's a file, a directory or that no such file/directory exists. – AMomchilov Oct 25 '12 at 1:50

Have you tried resetting Launch Services?

share|improve this answer
Thanks for the suggestion. I've tried it following the steps given in the link and unfortunately it did not solve my problem. – Saaru Lindestøkke Oct 22 '12 at 19:24
For recent versions of the OS, it's necessary to restart the OS (the article by The X Lab does not mention this). Why is a command line change to ~/Library/Preferences/ not effective immediately? Consider disconnecting all backup volumes before and throughout the routine. – Graham Perrin Oct 24 '12 at 2:20
I have restarted after the launch service reset. – Saaru Lindestøkke Oct 24 '12 at 2:41
up vote 0 down vote accepted

Although reinstalling iTunes did not help, updating did. I just downloaded iTunes 11 and now all icons are back where they should be.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.