Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My networked HP6310 suddenly stopped working today from my MBPro running Mountain Lion. Other laptops in the house (MB running Snow Leopard, MBP running Lion) can still print. I can connect via USB and print, so I don't believe it's the driver. I deleted the networked printer, intending to reinstall, but found that the printer is not found by Bonjour. I can access the printer on the web using the IP address, but not by using the address HP4xxxxx.local. I tried adding the printer by IP, but got this:

error msg

Suggestions on how to resolve?

share|improve this question
add comment

1 Answer

I apparently have the same issue, and when I try to browse the network using Bonjour Browser I get "Can't resolve link-local name" (see below).

In my case, the printer (HP LaserJet 2420) is connected to a ReadyNAS, and is connected to over the network via a CUPs server running on the ReadyNAS. Worked fine in Lion, not fine in Mountain Lion.

"Can't resolve link-local name"

Any ideas?

share|improve this answer
    
I just recently determined that my issue is related to wireless access. My troublesome MBPro connects to the network via wireless from my Verizon Actiontec modem/router; the other laptops connect to the network via a bridged Airport Extreme. If I connect to the network from the Airport wireless, I'm fine seeing and using the printer. I'm hoping to get Verizon to replace the modem/router to confirm that this really is the source of the problem. I've had Bonjour issues with other Actiontec equipment. FYI, the printer is connected to the Actiontec, not the Airport. –  Alice Nov 19 '12 at 15:41
    
I have a solution, although I'm unable to say why it works, or if I've lost something else in the process. A search on Bonjour/Actiontec/wireless yielded (yabfog.com/blog/2012/09/14/…) with the suggestion to disable IGMP proxy on the Actiontec router. No issues since I made the change. –  Alice Nov 27 '12 at 0:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.