Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am having the same basic problem as in this question:

AppleScript app started prompting to run or quit. How can I disable this?

However, in my case the "Startup Screen" option is definitely NOT checked, and re-saving the script will not make any difference.

The issue here appears to be that I am launching my script via a keyboard shortcut of CTRL-SHIFT-I and it's having the Control key as part of the launching shortcut, that is the problem.

I can change the shortcut, but I have a whole system in place with how I launch things and this breaks that system. I would really REALLY prefer not to have to change my shortcut for this one silly reason.

Is there any way to force-suppress this dialog in the applescript itself? Or any other way to cause this dialog to not appear?

share|improve this question

2 Answers 2

Holding control only shows those dialogs if a script is saved as an application. Couldn't you just save the script as scpt or applescript?

share|improve this answer
    
Sure, but then how do I execute it with a hotkey? I'm using Alfred and I can't launch the script unless it's an application. I've tried adding it as an extension but then when I hit the hotkey, nothing at all happens no matter what the hotkey is. I was able to launch the .app via a shell script, but then I can't assign it to a hotkey within Alfred, so it's far less than ideal. –  Jonathan van Clute Oct 6 '12 at 3:08
    
Have you tried checking the option to run AppleScripts instead of opening them in the advanced preferences? Hotkeys for extensions work for me. I mostly run scripts with FastScripts though. –  ؘؘؘ Oct 6 '12 at 6:20
    
Yep tried that too. Don't know why this was so stubborn for me but at least I found a workaround. –  Jonathan van Clute Oct 7 '12 at 2:48
up vote 0 down vote accepted

I solved this the only way I could make work. I created a simple Automator Application that runs my applescript. Then I assigned that app to a hotkey, and it works fine. The problem appears to only be that actually running an Applescript that has been compiled directly as an application, means you can't trigger it with any shortcut containing the control key.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.