Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Periodically my screen sharing stops working. When I try to connect nothing happens. telnet 5900 connects but I don't get the normal "RFB 003.889" prompt back. reboot seems to resolve it, but it stops working soon. I tried killing SCreenSharingAgent and it restarts, but still doesn't work. Any advice on how to make it work remotely via ssh?

(11.4.2 Darwin Kernel Version 11.4.2)

share|improve this question
11.4.2 relates to which OS X version? Do you have physical access to the computer of which you want to access the screen? – patrix Oct 5 '12 at 7:03
@patrix sorry, I assumed kernel version maps to OS X version. It is 10.7. Yes, I do have physical access. – MK. Oct 6 '12 at 2:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.