Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I usually use several different spaces (desktops?) for various different tasks.

Unfortunately, cocoa emacs 24.1 (9.0), even when using emacsclient (I do a server start in my init.el file) always opens a document or email response in the space emacs was originally started in.

Aquamacs seems better behaved in this respect, but I prefer cocoa emacs.

Is there a way to change this behavior?

Best,

JRV

share|improve this question
add comment

1 Answer 1

I've gotten at least a usable approach, tho not perfect.

The best I could do is the following:

1) don't ever use emacsclient and take start server out of init.el

2) in mission control preferences, uncheck the boxes for "when switching to an application..." and "group windows by application"

If I am editing more than one doc, in different desktops I end up with more than one instance of emacs running, but I can live with this. Also, the startup seems to be fast enough for me without emacsclient.

It doesn't look like cocoa emacs is impemented as a document based cocoa app. Is that the case?

Seems like Macvim handles the multiple document without multiple instance case more gracefully.

Best regards.

JRV

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.