Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I can establish a connection to my university VPN (Cisco IPSec). In addition I have to set a proxy, in this case I have the URL of a .pac file.

When I set this in the VPN-settings, the proxy is not used by Safari or Chrome. How can I set proxy settings for my VPN? I don't want to put this in the main network settings because I only need the proxy for VPN.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Setting it in the VPN connection settings works as expected for me.

Make sure you check the Web Proxy (HTTP) checkbox (or other types of proxies if required) and fill out the correct proxy server details. You probably also need to enable "Send all traffic over VPN connection" in the VPN's advanced configuration.

Afterwards, make sure you apply the settings by clicking on the Apply button.

Alternatively, you can set up different network locations. You can add a location in the Network preference pane and configure different values for the proxies and other settings on the main network interface. You will have to manually select the appropriate location for switching settings though.

share|improve this answer
    
That is what I did. It's auto proxy config with a URL of a .pac file. It seems like the system is using the settings of the network connection and not the VPN settings. –  Martin Preusse Oct 4 '12 at 12:46
    
I just noticed it only works for me when I send all traffic over the VPN connection, see my updated answer. –  Gerry Oct 4 '12 at 12:48
    
This setting is only available for PPTP VPN, not for a Cisco IPSec. I don't know the difference between those protocols, but my university uses Cisco IPSec. –  Martin Preusse Oct 4 '12 at 12:57
    
@emempe Maybe setting up multiple network locations is the solution for your situation then. –  Gerry Oct 4 '12 at 12:57
    
I set up a network location with only main network + VPN and set the proxy in both. Still not working, I think it's a technical issue within my current network. It kind of prohibits these settings maybe .. –  Martin Preusse Oct 4 '12 at 13:08

Under Mavericks this should work fine. Once you have all the security details set in your VPN connection click on Advanced and then Proxies.

Make sure you select Automatic Proxy Configuration and put the complete URL provided by your IT staff into the URL field. This will almost certainly be different to the proxy config file used by a computer that lives inside your network.

The proxy sheet

You don't want to send all traffic over the VPN. Now a web site internal to your network will use the proxy but those outside will not. This is the behaviour you want.

It may be useful to actually look at the .pac file. You can do that by entering the URL into the address field of your browser and it should be loaded as a text file.

The only case where you want all traffic to go over the VPN is if you are accessing an external web service that your organisation pays for that authenticates through the network - this is usually things offered by the library such as law services or special dictionaries.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.