Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Outlook 2011 on a Mac (OS X 10.7 Lion), on a (mostly PC) office network using Microsoft Exchange server.

In Outlook 2011, in the network "Sent Items" folder, all emails are listed showing the sender's name (my name), not the recipients' names.

That means every single email is headed with my own name, like this:

My Name                     08/09/2012
Some subject line               [flag]

My Name                     08/09/2012
Re: Another subject line        [flag]

My Name                     07/09/2012
Re: different subject line      [flag]

My Name                     07/09/2012
different subject line          [flag]

...and so on. There's no clue at all as to who these emails were to, until I open each and every one.

I guess it's reassuring to be told that every email that I sent was sent by me and if I was ever to forget my own name while browsing my sent emails folder, it'd be super useful, but it's not very helpful for navigating sent emails.

Is this normal for Office for Mac 2011? How can I fix this, so that the list shows the recipients' names instead of endlessly reminding me of my own name?


Things I've found while researching this:


A simple guide on how to fix this would be the best answer, but I'd also welcome any knowledgable thoughts from people with experience of Macs on Microsoft Exchange Server networks on whether this sounds like an Outlook settings issue which I can fix on my machine, or some issue relating to how the Mac gets data from the server and network. The fact that Apple Mail users have encountered the same issue with no apparent fix makes me think the problem might be in the interaction with the network rather than the mail client - but that's way beyond my limited knowledge of these things.

I don't know whether the local ("On my computer") Sent Items folder has the same problem, as it's configured so that no emails except drafts are ever stored in these local folders. Drafts saved locally are listed by recipient as expected.

share|improve this question

migrated from superuser.com Oct 3 '12 at 23:04

This question came from our site for computer enthusiasts and power users.

add comment

8 Answers 8

up vote 5 down vote accepted

Changing the "Arrange By" value from "Date received" to "Date Sent" on the top of the mail list solved this issue for me.

share|improve this answer
add comment

Note that if you are using Outlook 2011 for Mac with Exchange then you may have to right-click/control-click on 'Sent Items->Folder Properties' and then click 'Empty" to empty your cache before this technique of switching from 'Date Received' to 'Date Sent' will actually work. You need to have your 'view->Navigation Pane" selected to see the 'Sent Items' folder you have to click on. Once I emptied my cache, this worked like a charm. Thanks!

share|improve this answer
add comment

Click on the sent icon between inbox and drafts.

You may need to do this each time you access the sent lists. It works for me. Not satisfactory, but achieves the desired result.

share|improve this answer
add comment

I am not a Mac power user but I did have to try and solve this same problem. I have 4 different email accounts I am managing through Outlook 2011 for Mac. In 3 of the four my sent email list displays who the email was sent to. I could not figure out how to get the fourth to also display this way. I solved my problem using the other hints here, however, they were not a perfect solution for me. I don't know why.

Here is how I was able to address it. It's not perfect but it's working for me:

  1. First I had to hide the reading pane (View/Reading Pane/Hidden).
  2. Then I "right clicked" in the bar where the column headings are above the list of from emails.
  3. I unclicked "From" and I clicked "To". I then moved the "To" column by clicking it and dragging it where I wanted it.
  4. I went back and unhid the reading pane. Unfortunately I can only view it on the bottom. It was being viewed on the right before but if I view it on the right the sent list goes back to showing my name as the sender and not the recipient name.
share|improve this answer
add comment

I was able to solve the issue by changing the "Arrange By" choice to "Conversations".

share|improve this answer
add comment

I simply right click on Arranged by then click on custom, then open fields and move To to the list on the right panel if it is not there and then move to the top.

The recipient name will appear first in the "Sent Items" list, and it will be still arranged by date received.

share|improve this answer
add comment

I fixed this by changing the reading pane view from right, to below and then switching back.

share|improve this answer
add comment

For Outlook 2013, while sent folder is highlighted (clicked on the sent folder), click the view tab, click the view settings tab, click columns, and add "To". Move Up "To" to the very top and click ok. This should fix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.