Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've had mobile documents syncing in iCloud working for a while now, and suddenly a few weeks ago it stopped working. Third-party apps like GoodReader and Downcast no longer sync between my devices and Apple apps like iPhoto no longer appear to publish to or read from iCloud.

My first instinct was to go to Storage Management to manually delete files that may have been causing a problem. However, the only data that shows up are 0.1kb for iPhoto and 0.6kb for Downcast and if I delete either one, they still remain listed. My storage total indicates that the files from GoodReader are present, but I seem to have no access to them.

I have tried all of the standard solutions - uninstall/reinstall, Turn Documents & Data off, then back on (I have currently had it off on all devices for hours to attempt to force a "reset"). I have restored devices and even setup my new iPhone 5 as a new device rather than restoring - the problem showed up on the device almost immediately. I have moved/deleted the "Mobile Documents" folder and had it successfully reappear. I have done the same with the ~/Application Support/Ubiquity folder.

I have a Developer account, and looking at the documents at, I see about 25 versions of the folders for each applicable app (ie, 25 Downcast folders, 25 iPhoto folders, 25 Shoebox folders, etc...). The contents of these folders are not identical. This seems wrong, but I don't know how to do anything about that as the folders don't match any of my local storage options.

If I run the Ubiquity Daemon on my Mac and manually publish a PDF in Goodreader it will show up in my Mobile Documents folder on the Mac but never actually upload to iCloud (the upload arrow remains on the file's icon and it never shows up on One file showed up there, but with a "failed to upload" icon).

I'm hoping that someone with more knowledge of how iCloud's Documents & Data storage works has some suggestions, as I don't know what else to try. The problem appears to be with the data stored in the cloud rather than with any of my individual devices, but I don't know if it's possible to delete/reset that data so that sync will work again. I should note that other iCloud functions work normally (calendar, notes, reminders, etc).

Thank you in advance for your help!

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.