Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm in Canada, and I use my mac to write documents in both English and French. Generally, I find that the built-in spellchecker (on 10.7.4) does a great job of automatically detecting which language I'm using, and makes language-appropriate corrections (i.e. it recognizes misspelled French as misspelled French, rather than misspelled English).

It fails at this task, though, in one specific TextEdit file which is my "new vocabulary list". In this document I write down new French words that I've learned alongside their English translations. Since the two languages intermingle so closely in this file, the spellchecker often gets confused, and ends up "correcting" legitimate French words because it thinks they're misspelled English.

This is annoying. Does anyone know if it's possible to either

  1. turn off spellchecking completely for this document only, or

  2. specify to the spellchecker that it should only use one dictionary (i.e. French) for this document.

(If I had to choose one language for the spellchecker to work in in this document I'd prefer that it used French, since that's the language I'm less comfortable with. If it mangles my English I'll notice and be able to make corrections; if it mangles my French I might not.)

share|improve this question
    
I posted a similar question here: superuser.com/questions/470844/… –  Maverik Oct 3 '12 at 16:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.