Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This "phoning home" reporting is something I would like to completely disable.


How can I make sure I never see this dialog again and no info is sent to Apple?

share|improve this question
Clicking on "Forever" and "Deny" doesn't work? – patrix Oct 3 '12 at 9:21
Nope because I am not stopping the service, just denying network access to it. I'd like to stop the execution of that code which attempt to phone home... – Robottinosino Oct 3 '12 at 9:26

Going to System Preferences > Security & Privacy > Privacy > Diagnostics & Usage and unchecking Send diagnostic & usage data to Apple did not work for me. I still get the Little Snitch dialog asking for permission to connect to

It seems the connection attempt is triggered by a launchd job located at /System/Library/LaunchDaemons/ On Mountain Lion 10.8.4, it's set up to run every day at 11 am. If I clear the Little Snitch rules for the SubmitDiagInfo process and run the following command to start the launchd job sudo launchctl start, the Little Snitch connection dialog pops up.

This seems to be a bug as the DiagnosticReportCleanUp job is not respecting the Privacy setting in System Preferences. I've denied the connection attempt Forever in Little Snitch for now. Hopefully, this gets fixed in OS X 10.9 Mavericks.

share|improve this answer
The service can also be disabled permanently with sudo launchctl unload -w /System/Library/LaunchDaemons/ – user495470 Jul 14 '13 at 1:59
Thanks, but wouldn't that also stop the job from performing whatever diagnostic report cleanup it's responsible for? Ideally, I'd like the job to run and perform cleanup, but not actually send the report information out. – Eric Jul 14 '13 at 6:10
I guess, but it won't probably matter if those files are kept or not. According to man SubmitDiagInfo, all files eligible for automatic reporting are shown under the DIAGNOSTIC AND USAGE INFORMATION heading in Console. – user495470 Jul 15 '13 at 2:54
  1. System Preferences > Security and Privacy > Privacy > Diagnostics and Usage.
  2. Click the Lock icon in the bottom left, enter your password and uncheck “Send diagnostics and usage data to Apple”.
share|improve this answer

Unloading the service does not seem to stop the submissions:

sudo launchctl unload -w /System/Library/LaunchDaemons/

But after restarting it works for me:

sudo execsnoop|grep SubmitDiagInfo
share|improve this answer

I too am seeking an answer to this. Unfortunately using the system preferences Privacy option has no effect (i.e. unchecking the box still allows SubmitDiagInfo to run). similarly, the setting in Console Preferences has no effect.

It would seem that Apple is so keen to collect this information they ignore the privacy settings they have given you.

I can see in the Console application the data that is to be sent - not crash dumps but routine system usage data (things like "clamshell sleep", "restarting on AC power 99%", etc.

I also don't want the service to run. I have blocked the data going out through Little Snitch, but it periodically keeps retrying whilst the volume of data to be sent keeps growing !!

To summarise, it seems that there is no way to prevent the reports from being sent, as the option to do so is seemingly ignored, and you should consider using tools like LittleSnitch etc to block it instead until this is fixed.

share|improve this answer
Please read the FAQ, especially – patrix Oct 15 '12 at 9:53
Changed content should be clearly flagged as to who wrote it ON THE MAIN PAGE. Just changing what somebody wrote and making it appear that they wrote it - even if they do not agree with the advice is disgraceful. Nothing to stop somebody adding their own post - but when I do not agree with something I do not want it attributed to my name !! – stuartMy Oct 15 '12 at 10:00
You can always rollback to your original version. Main problem I see is that your original answer is not really providing an answer at all, something which @stuffe tried to fix by summarizing your points. – patrix Oct 15 '12 at 10:11
Changed content should not be flagged as to who wrote it. – Daniel Oct 15 '12 at 12:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.