Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running OS X Lion and my laptop has a 320GB drive. I bought a larger drive (750GB) and cloned the entire device from the old drive to the new using GNU ddrescue. After cloning everything looks fine but of course I have a lot of free space.

Initially, resizing the original 320GB partions using Disk Utility was not successful dragging the partition to the full disk size and pressing “Apply” changed nothing), so inspired by this answer (which gave me the promise of being able to recreate my recovery partition), I tried to delete the recovery partition first to make sure there was no partition in the way for the resize. Still, resizing (enlarging) the partition is not possible.

Listing the partition map using diskutil looks like this:

$ diskutil list /dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *750.2 GB   disk2
   1:                        EFI                         209.7 MB   disk2s1
   2:                  Apple_HFS Macintosh HD            319.7 GB   disk2s2

Trying to resize from the command line I started to have a look at the limits for resizing:

$ diskutil resizeVolume /dev/disk2s2 limits
For device disk2s2 Macintosh HD:
        Current size:  319.7 GB (319728959488 Bytes)
        Minimum size:  319.1 GB (319106846720 Bytes)
        Maximum size:  319.7 GB (319728959488 Bytes) 

So for some reason, I am not allowed to resize the filesystem in /dev/disk2s2 to use the full capacity of the drive.

Any ideas why there is this limit and how to surpass it?

Here is the diskutil info of the drive:

$ diskutil info /dev/disk2
   Device Identifier:        disk2
   Device Node:              /dev/disk2
   Part of Whole:            disk2
   Device / Media Name:      ST975042 0AS Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      GUID_partition_scheme
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               750.2 GB (750156374016 Bytes) (exactly 1465149168 512-Byte-Blocks)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                Yes

   Whole:                    Yes
   Internal:                 No
   OS 9 Drivers:             No
   Low Level Format:         Not supported

and here is the diskutil info of the problematic partition:

$ diskutil info /dev/disk2s2
   Device Identifier:        disk2s2
   Device Node:              /dev/disk2s2
   Part of Whole:            disk2
   Device / Media Name:      Customer

   Volume Name:              Macintosh HD
   Escaped with Unicode:     Macintosh%FF%FE%20%00HD

   Mounted:                  Yes
   Mount Point:              /Volumes/Macintosh HD 1
   Escaped with Unicode:     /Volumes/Macintosh%FF%FE%20%00HD%FF%FE%20%001

   File System Personality:  Journaled HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended (Journaled)
   Journal:                  Journal size 24576 KB at offset 0x15e51000
   Owners:                   Disabled

   Partition Type:           Apple_HFS
   OS Can Be Installed:      Yes
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported
   Volume UUID:              1914E88D-9558-3DBD-8254-9936B20E907A

   Total Size:               319.7 GB (319728959488 Bytes) (exactly 624470624 512-Byte-Blocks)
   Volume Free Space:        6.0 GB (5990821888 Bytes) (exactly 11700824 512-Byte-Blocks)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         No
   Ejectable:                Yes

   Whole:                    No
   Internal:                 No
share|improve this question
I suspect that ddrescue copied some aspect of the partition map that indicated to diskutility that the partition can't be extended. What happens if you use CarbonCopyCloner instead? – Sherwood Botsford Mar 18 '13 at 20:28
Sorry, its a long time ago, so I fixed it by copying using Disk Utility's "Restore" option instead. As far as I remember the new volume was initially resized to the full size of the new disk. However, I am still puzzled why the ddrescue copy could not be resized which is why I left the question here. – mgd Mar 20 '13 at 13:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.