Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Had a quick question about having emacs-like word skipping in my terminal. I had set this up pre-upgrade to Lion and had ctrl-left & ctrl-right set to \033b & \033f respectively. Unfortunately post-upgrade ctrl-left & ctrl-right don't seem to be working any more.

I have seen this solution which makes alt-left & alt-right behave as above, but I was hoping to get ctrl-left & ctrl-right working as before and I was wondering if folks here had any solutions.

PS: As an aside this behavior is not working correctly in my VNC client as well - which it did previously.

share|improve this question

2 Answers 2

⌃← and ⌃→ have moved a word left and right by default in Terminal since 10.7.

You can also change them in other applications by creating ~/Library/KeyBindings/ and saving this as DefaultKeyBinding.dict:

{
    "^\UF702" = moveWordLeft:;
    "^\UF703" = moveWordRight:;
}
share|improve this answer
    
I don't have a 'Library' under '~' and no 'KeyBindings' under '/Library' –  decimus phostle Oct 4 '12 at 18:09
1  
~/Library/ was hidden in 10.7, but you can open it from the go to folder sheet. There's no KeyBindings folder by default though. –  Lri Oct 4 '12 at 18:39
up vote 1 down vote accepted

Turns out that Mission Control(in Lion) has the same key combination to Move left a space and Move right a space - which I particularly don't have use for. Disabling this in Settings -> Keyboard Shortcuts did the trick for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.