Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My mid-2011 iMac running Lion 10.7.5 has an intermittent problem. When I resume from sleep in the morning the ethernet fails to come up reliably. Sometimes it starts working immediately, sometimes it takes 10-20 seconds, and lately the problem seems to be getting worse and it can take minutes.

I can fix the problem by going to a terminal and disabling and re-enabling the ethernet with ifconfig en0 down; ifconfig en0 up. And after sleep I can connect to the same network via WiFi, just not ethernet.

The network is a simple home network with switched gigabit ethernet. There's one Netgear switch and one router: a Linksys WRT54GL running Tomato firmware. I don't have any useful logs on the router side about what's going wrong. In general the network works fine, including when booting the iMac, it's just this one resume from sleep that's failing.

On the Mac side, the kernel logs don't have much useful information. Just a lot of lines like this:

Oct  2 06:02:48 iMac kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link up on en0, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [796d,0103,0de1,0300,c5e1,0c00]
Oct  2 06:02:49 iMac kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link down on en0
Oct  2 06:02:53 iMac kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link up on en0, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [796d,0103,0de1,0300,c5e1,4c00]
Oct  2 06:02:54 iMac kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link down on en0

A packet trace via Wireshark only gives a little more insight. All I see is an endless stream of unanswered ARP and DHCP requests, along with some IPv6 stuff I don't understand. Screenshot below is representative.

Packet dump screenshot

When I use ifconfig to bring the network down and back up, the main difference I see in the packet trace is my ARP and DHCP requests get an immediate answer.

share|improve this question
    
Looks like this question is going to get no answers. FWIW, my workaround has been to enable Wifi as well; it seems to work right on resume from sleep and once the ethernet wakes up the routes switch over to wired network. –  Nelson Nov 17 '12 at 20:34
    
I do see the same error on a MacBook Pro running SnowLeopard 10.6.8. The kernel error message is: Feb 14 19:57:42 sagan kernel[0] AppleBCM5701EThernet: 0 0 enable - failed But ifconfig asserts the Ethernet interface is up. I'm still hunting this problem which is clearly related with the sleep mode. –  daniel Azuelos Feb 14 '13 at 19:16
    
The version I have is characterized by: Kext name: AppleBCM5701Ethernet.kext Firmware version: 5764m-v3.38, 0x56cdb6d5 Version: 3.0.5b8 –  daniel Azuelos Feb 14 '13 at 19:35
    
FWIW, I think that may be a different problem. On my system I don't seen that "enable - failed" error. I can't remember if ifconfig shows the Ethernet interface up, but if it is up it's not configured with an IP address. –  Nelson Feb 15 '13 at 18:13
    
Same result of ifconfig en0 up: UP but no @IP. –  daniel Azuelos Feb 19 '13 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.