Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My Macbook Pro mid 2012 (non-retina display) keeps showing me that the startup disk is full. I have only one partition for the whole system and it is 750 GB in size. I am sure that all my files account only for 200 GB max. Suspecting a hard disk error I ran the disk utility's verify disk and repair disk but it showed no errors. Within the console windowserver and networkd were repeating on and on!!

I then used another productivity software named OmniDiskSweeper to check out my disk. I was surprised to find that within my usr/bin/ directory i found many clones of the usr directory. i.e. main root/usr/bin/usr/bin/usr/bin/usr/bin...........(many directories in this fashion and finally all of my hard disk excepting 25 MB is full). The size of a single bin directory was 40 GB and there were about 12 usr/bin within it's previous usr/bin. I tried deleting the duplicate directories created in OmniDiskSweeper itself.

But I keep getting a console error message stating that the UI of windowserver was force disabled by OmniDiskSweeper and immediately the next second I get that OmniDiskSweeper has forcefully re-enabled UI of windowserver and my whole hard disk is still full!! I also tried booting it up in safe mode but still it has been on the grey apple logo screen for 15 hours until now (and still going on) with no visible progress.

What could be the problem here? Any help?

Thanks in advance!!

share|improve this question
    
This sounds like a severe issue with the filesystem or the hard drive itself. Search for "booting into recovery mode" either here or on support.apple.com –  patrix Oct 7 '12 at 8:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.