Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I hadn't backed up to Time Machine in 20 days, and now that I am trying to do so I have yet to succeed.

It got stuck a few times with a few KB; other times it took forever do everything, from preparing the backup to actually transferring files. It's supposedly trying to backup 40GB and after 8 hours not even 1 GB is done. I have to stop it because I have to take my 2009 Macbook running Lion out.

I ran Volume Repair on the external HD and everything came back fine. I also tried manually copy pasting a large video file to that volume and it copied quite fast. So must be something with Time Machine itself.

Can anyone help?

Speaking of 40GB I feel like that's way too much data that has changed over 20 days. I don't think that is correct. How can I check what is being backed up anyway?

Edit:

I ran tmutil. Final tally:

Added:         18.4G
Removed:       13.3G
Changed:       19.1G

Is this what TM means when it tells me it's backing up 40GB? Including stuff that will be removed?

share|improve this question
    
What Max OS X version do you use? Since when does this problem occur? –  user18805 Oct 1 '12 at 6:35
    
I am on 10.7.5. This happened after 20 days of not backing up, which was on September 28th. –  rabbid Oct 1 '12 at 15:07
2  
Then 10.7.5 is the cause for your problem. See apple.stackexchange.com/questions/65486/… –  user18805 Oct 1 '12 at 15:34
    
@Tichodroma yikes that sounds really bad. Will see if there's another update that fixes this. Otherwise will do what the first answer says. Thanks! –  rabbid Oct 1 '12 at 15:42

2 Answers 2

Killing Spotlight before running Time Machine did it for me. Backing up about 30 MB/s now.

To disable Spotlight indexing, open the Terminal utility and run the following command:   sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist  

To re-enable Spotlight indexing, you can repeat the above command and change the word "unload" to "load," as in the following:   sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist  

share|improve this answer
1  
Killing Spotlight is not a solution to any Time Machine problem. Time Machine relies on Spotlight for indexing. If it appears as though it is working, it is incomplete because the indexes will not be updated in the process of backing up your data. –  jschmidt Oct 9 '12 at 12:43

I believe this is a staleness prevention. That whenever there is too long between backups Time Machine uses a more thorough way to ensure that the backup is complete.

It is my understanding that the 40 GB is a "this is how much we consider for backing up" and that the actual data transferred may prove to be a lot less if the files turned out to still be identical.

Based on your description I believe that you have reached a point where you need to let your Time Machine backup catch up - work on its own until it is done, if at all possible. If you cannot wait for that, perhaps now is a good time to buy a new drive and use that instead and have the old drive as a backup backup.

share|improve this answer
    
thanks for the input. I'll try to let it run and see what happens. –  rabbid Oct 1 '12 at 15:08
    
I have been very satisfied with a time capsule. Then the backups happen daily. –  Thorbjørn Ravn Andersen Oct 1 '12 at 15:39
    
With a backup that big, you should use wired ethernet. –  jalynn2 Jan 10 '13 at 20:22
    
Wired ethernet will allow faster file transfers. I, however, get above 10 megabyte/second over wireless, so it is rarely needed on a regular basis, after the initial backup finises. –  Thorbjørn Ravn Andersen Jan 10 '13 at 23:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.