Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My MacBook Pro screen constantly dims and brightens. The automatic box is unchecked. The brightness adjustment button is constantly moving back and forth.

share|improve this question
    
That sounds like a software issue. I would take it to an Apple Store if there is one close to you. If not, you may need to do a re-install. –  Zrb0529 Sep 28 '12 at 17:16
add comment

5 Answers

I'd try to reset the System Management Controller (SMC).

Apple's documentation on the SMC states that this may resolve issues related to the power management. The document specifically mentions:

The display backlight doesn't respond correctly to ambient light changes on Mac computers that have this feature.

As the guidelines on how to reset the SMC depend on your kind of Mac, I will not list them all here. Please follow the link and go to the section with the title Resetting the System Management Controller (SMC) for more information on how to apply the reset.

Should that not work, you're left with two other avenues to remedy this:

  • software errors - you might need to troubleshoot or restore the OS
  • hardware fault - the display and sensor might simply need repair
share|improve this answer
add comment

Might be an issue with the power supply when “Slightly dim the display when on battery power” is checked in Energy Saver prefs. This would dim the display when the power adapter is lost and become brighter again when not running on battery anymore.

share|improve this answer
add comment

Go your System Preferences, select "Displays", and uncheck Auto-adjust Brightness.

share|improve this answer
    
Isn't this the same as the OP saying they unchecked the automatic box? –  bmike Oct 30 '13 at 11:07
add comment

This could be a keyboard issue. If other things are going wrong with keys, such as the backspace or caps lock, the keyboard (top case) needs replacing.

You can get a temporary fix by using a keyboard remapper program and change the keys for brightness and turn off the usual F1 and F2 ones.

share|improve this answer
add comment

Maybe the ambient light sensor?

share|improve this answer
    
As the OP states, the sensor is turned off in the System Preferences. –  gentmatt Sep 28 '12 at 17:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.