Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am working with an school trying to load print drivers on iBooks running OS 10.6 and 10.7. I loaded the latest drivers for the printers but found that they did not work correctly. I went to the Library and removed all the drivers and PPD's. When I tried to load the earlier version of the driver I get the message "A newer version of this driver already exist on this computer" and it will not let me load the driver.

I tried the same procedure on my personal MacBook Pro 10.8 and I can load and unload the drivers with no problem.

Any clues as to why this is happening?

share|improve this question
    
Your first problem comes from the fact that iBooks have G3 or G4 PPC processors, and Mac OS X 10.6 and 10.7 are Intel only. Any chance either the hardware or the software is something other than what you specified? –  Daniel Lawson Sep 28 '12 at 0:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.