Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a problem with my 2TB (I think Gen 2) TC.

It was connected directly to a cable modem and was working fine for over a year. A few days ago, I started to get connection errors (no IP) on both the Ethernet and wifi ports. The wired computers are connected to the TC through a hub.

I changed the connection to link to the net through a spare router, and changed the TC to "Bridge Mode".

All the connected (Ethernet) ports work ok. I have no WiFi mode though (from the TC).

I can see the TC and even do a Time Machine backup to it.

Before I plonk $300 on a new device, I would appreciate any troubleshooting tips..

share|improve this question

Are you running the latest firmware and have you already tried resetting the TC to factory defaults?

share|improve this answer
I do have the latest firmware (7.6.1). I've tried to reset it by unplugging, holding the switch in the back for 5- 10 seconds, but somehow, I'm not sure that really got the device back to factory settings. Is there a more robust method? – David DelMonte Sep 28 '12 at 1:18
I thought you could reset ir from the GUI itself. Anyway, this should help you out: – Vincent Sep 28 '12 at 1:21
up vote 1 down vote accepted

For others who are having this issue, the hardware is ok. The problem is with the current version of firmware - 7.6.1.

I finally found this site that allowed me to use Airport Utility 5.6 with Mountain Lion. Using Frank's patch (see the site link above), I was able to roll back the firmware version to 7.6.

To do this, open AU 5.6 and select Manual Setup enter image description here

Hover over the Version, and you'll see the little arrow.

enter image description here

Then click Version and select the software version. (7.6 seems ok). Ignore calls to update after this.

enter image description here

share|improve this answer
+1. Was having some issues with Time Machine backing up to the Time Capsule drive on 7.6.1. Used this tip and backups are working fine all around once more. Thank you! – Terrance Shaw Oct 16 '12 at 3:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.