Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm running Mountain Lion with a retina MacBook Pro with three external monitors attached. Quite often, one or more of the monitors blacks out. Normally, I would choose "detect displays" in the displays menu or system preference, but I just found that that button is no longer there. Furthermore, the displays menu is gone as well! I found it in /System/Library/CoreServices/Menu Extras, but when I double clicked it, it didn't open.

So I guess I really have two questions:

  • Is the displays menu dead? Or did I break my computer somehow? I don't terribly miss it, other than the detect displays command (I never change the resolution from the default).

  • More importantly, how can I execute a "detect displays"? A terminal command would be fine.

share|improve this question

2 Answers 2

up vote 7 down vote accepted

From Apple KB Article HT5369:

If the detect displays option is not available, hold down the ⌥ alt/option key while you are in the Display pane.

It should morph the "Gather Windows" button into the "Detect Displays" button.

Stupid change, isn't it?

share|improve this answer
    
Sadly, this did not fix my black monitor issue (suggestions on that welcome). But at least it's good to know that the feature is still there somewhere. –  asmeurer Sep 26 '12 at 4:54
    
@asmeurer It's probably just that the graphics card has to do too much work, for all the rMBP's awesomeness the GT650M just isn't meant to drive four monitors (one of them being 2880*1800!) –  Simon M Sep 29 '12 at 7:38
    
OMG, I do not understand OS changes like that. It's a very nice hammer, why turn it into a shovel-hammer. It works. Still +1 from me as soon as I get some more votes, this was really annoying me. –  Deesbek Oct 15 '13 at 13:30

For a MacBook Pro with Retina Display, you may simply want to switch the Resolution option in the Displays panel of the System Preferences. If you've currently selected "Best for Retina Display" then switching to "Scaled" and back may fix your problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.